Activation Problem - like those recorded April 3


#1

What phone do you have? Moto G4 Play

What plan are you on? My Choice Talk & Text + 1 GB Cell Data

Does your plan include data, or just talk & text? both


Issue Description

I see similar activation issues from April 3. On Tuesday, Nov 6, I traveled to a location where service was almost non-existent. But when I drove to a site where 3G was available the 'Activation Required' message prevented any phone or text actions. Was still able to do email and Maps but it was no longer a "phone". Went to a McDonald's for their wifi to try and get it working again - no luck. Did that three different occasions over a 5 day period. Incredibly my wife reached my by calling from her RW phone but no other phone functions would work. Got home to our friendly home wifi and did the same things I had tried before and miraculously it started working! What's up? Don't want to travel again without the phone working.

#2

I recommend you enter *#*#8647#*#* into the dialer to resolve this issue. This link will give you video directions on the process. https://community.republicwireless.com/videos/1040


#3

#4

@leonards.x6fqqd Are you still having an issue?


#5

The issue went away when I arrived home and was back on my friendly home wifi. I was prepared to research and do battle to get things working but they just started working correctly.

My concern is this: I was out of town in areas where there is no phone service and no wifi. That was expected. However, when I went to town and tried to check phone messages and texts, nothing worked. This was tried on 3 different occasions using McDonald’s wifi. So my Moto G4 Play quit being a phone. Email and Google Maps worked, for example, no phone stuff.

Why did this happen? Will it happen again? How do I fix it while out in the boondocks? This is what worries me.

Thank you.


#6

When you were on the McDonalds wifi, did you open a browser and accept the terms and conditions? If so, it is likely that the network was simply blocking the necessary ports. That’s fairly unusual for McDonalds, but pretty normal for public wifi.


#7

I don’t recall seeing a request to accept T’s and C’s. By browser, if you mean access to GMail, that worked fine.

The prevailing question remains: why did my phone go into “Activation Required” mode. At times I had fairly strong 3G available, don’t remember seeing 4G.


#8

When connecting to wifi at McDonalds, you have to open a browser (Chrome) and select “I Accept” at the top of the page in order to be granted unfettered internet access. Without doing this the phone wouldn’t be able to reach Republic’s servers in order to place/receive a call.

As far as activation required, that can happen when the phone repeatedly fails to be able to connect to the cellular network. You can avoid this by putting the phone in airplane mode when in areas where there is no cellular coverage at all so that the phone will stop trying repeatedly to connect to the network.


#9