After All These Years, This Is Still A Problem

Phone: Pixel 3a XL

Plan: My Choice w/ Data

Issue Description

I’ve been with RW since 2012. To this day, I have had the same issue with calls not coming through while in airplane mode, but with WiFi enabled (VoIP only mode). I’ve had various Motorola phones, Google Pixel… doesn’t matter. I’ve had Linksys, Asus, Netgear, TP-Link and other routers, but always the same issue. I can be holding the phone in my hand and suddenly see the Voicemail icon pop into the notification area because my phone did not ring and the call went straight to voicemail. Voicemail notifications come in immediately. Never had an issue with SMS not coming in.

Other people have had this same issue and there was quite some discussion about a few years ago. I’ve just lived with it. But, it’s starting to become unacceptable. Today, my girlfriend tried to call me half a dozen times from various locations after leaving her dental appointment. None of the calls came through to me. My phone gave absolutely no indication that a call from her phone ever rang on mine, and she indicates that the calls go straight to voicemail every time.

I like RW. I want to stay with RW. But, there are too many options out there, and I would probably get calls without the caller having to go to voicemail.

Are others still experiencing this issue? Does anyone have a solid clue as to why this is happening? It’s been going on for 9 years, now. I can’t imagine RW engineers don’t have a handle on this.

1 Like

I am not, however, I do not generally use my phone in WiFi (VoIP) only mode.

The consensus of opinion for newer compatible phones is Android’s Doze. @jben would be the Community’s in-house expert on that.

I’m not saying it should be necessary but you might consider Republic’s Extend Home adapter as an adjunct to your Republic cell service. It’s VoIP only without the overhead of Android’s Doze and uses Ethernet to connect to the Internet rather than WiFi. As good as Republic’s WiFi calling (and text messaging is) for most folks most of the time, with VoIP a wired (Ethernet) connection is generally superior to WiFi. There’s no ongoing monthly expense for Extend Home though the device itself does come with a price attached.

Regarding another service provider being more reliable. That’s certainly potentially true. If you’re running in VoIP only mode because your cellular signal is poor, another provider with poor cellular signal wouldn’t necessarily be an improvement. I fully appreciate many alternate providers offer WiFi calling and text messaging as well but, in my experience, their efforts may or may not be adequate in areas of poor cell signal.

Hi @beachb,

Welcome back to our Member Community!

Thanks for the update. I’m sorry to see that the issue continues to be a problem for you no matter what phone and no matter what router.

I second @rolandh’s suggestion that Extend Home is a great workaround to make sure you don’t miss calls. But it’s only a workaround, and not a solution.

It has been a very difficult issue to replicate because, as you’ve described, it seems to impact members in a specific cellular coverage environment, and since it has been difficult for our engineers to replicate, it has been particularly difficult to investigate and resolve.

However, we’ve made some inroads recently, thanks in no small part to an incredible amount of tireless testing by one of our Ambassadors and some great additional feedback from another Community member, both of whom have been working with one of our App developers to really hammer away at this issue.

I don’t have an ETA for a solution but it’s not a joke or brush-off to say that we believe we are truly closer than we’ve ever been to solving it.


I know that Android’s “Doze” feature has been suspect, and I don’t know the specifics on how the Doze feature is implemented. But, I would think the phone would not be dozing when the screen is on and I’m scrolling through the Play Store to see what updates are available for my installed apps. That’s happened more than once. Or, when I’m in the Settings doing one thing or another. It’s happened then, too.

I don’t think there is much I can do with the phone, itself, to alleviate the issue. But, I can’t help but believe their might be settings in the router, some sort of timing interval or something, that might mitigate the problem. I’m not networking savvy enough to dive into that jungle. I’m sure I would do more harm than good.

However, the whole time I’ve been a RW customer, I’ve also had Ooma, and I’ve never had an issue with Ooma, at all. Not sure what to make of that, except that, as is the general consensus, it must the Android implementation of the Doze feature.


I’m inclined to agree.

It’s a possibility. What router are you currently using?

I don’t know if Ooma is doing anything that would mitigate potential router issues. I would note that Republic’s Extend Home adapter like Ooma’s Telo uses an Ethernet connection to the router. My expectation is it would work as well as Ooma on your network and would share your Republic number. My apologies if it’s sounding like I’m pitching Extend Home. It’s not my intent.


Send them to my address for a day. I experience this issue almost on a daily basis. Of course, the car never makes “that noise” on the day you take it to the mechanic. But, this “straight to voicemail” issue is pretty consistent with me. So consistent, in fact, over so many phones, versions of Android and different routers, I’m really surprised more people don’t complain about it. I can’t possibly have that much bad Karma all to myself!


rolandh, current router is a new TP-Link AX1800 w/updated firmware. Extend Home is being discussed. :+1:


From what I see in Community, your experience is most commonly shared by others relying on WiFi only. Most folks don’t share the experience because while they’re relying on Republic’s WiFi first service, they have sufficiently robust cell signal that it’s not WiFi only.

I think option 2 is a possibility. It’s mentioned here: Archer AX20 & AX1800 V1 User Guide | TP-Link. I’m hopeful @jben will drop in and opine on that.

1 Like

Well, this one quickly got out of my area of knowledge. I have never had any problem with the normal NAT, except when getting into double NAT’s (router behind another router) we might ask @cbwahlstrom to weigh in on the Port Forwarding question.

  • At this point, my guess is that @beachb may be hitting two problems.
    • Doze will not be active if the phone screen is lit up, or the device is on the charger
    • When the problem occurs (with phone in hand and lit up, what is does the RW App show in the Notifications/Status?

Is there no cellular signal available in the OP’s home? I guess I don’t see port forwarding or triggering as the answer. If you want to eliminate NAT, just stick the phone in the DMZ for a day or so,. Even if that were to work, the doze issue remains.

That’s a bit of a curiosity, as well. When I hit the Power button to see the lock screen, just before touching the finger print sensor to open the phone to the Launch screen, it says “null - Republic” in the notification area. Now, I touch the finger print sensor and go to the Home screen. The RW arc is briefly solid, then goes hollow and stays hollow. I don’t know if this is expected behavior or an anomaly. I always thought that a hollow arc indicated there was no internet connection?

CBW, no, there is a very unreliable Sprint/T-Mo cellular signal at my address. Sometimes, I can manage a call. Depends on which way the wind is blowing. If I could get my neighbors across the street to cut their trees down, it might be a little better. But, I’m not counting on that to happen.

No, it just means that some aspect of Republic Wireless’s service is not registered with the mother ship.

I reset my connection, but, the arc is still hollow. No restrictions on RW app using batter in the background.

That would be because you are in Airplane Mode

  1. Airplane Mode : Not connected to the cellular network
  • Airplane mode is enabled. This state is unaffected by WiFi being enabled and/or being connected for Republic calling.
  • Empty blue arc

Taken from What are the Connectivity Status Notifications? – Republic Help

1 Like

Thanks, jben. That, of course, makes sense.

1 Like

Just wanted to chime in here that I complained about this in a long thread last year. Since then, with Republic’s help, I switched SIMs to Sprint and the problem has gone away. Just to be clear, what I was experiencing was “call, no ring” when my phone was dozing.
I very occasionally am put on cellular when my Wi-Fi is strong, but many of these annoying issues are much less. I think RW is making general progress on improving Wi-Fi/cellular operability.
I am now considering the Extend Home option but I am confused about what a phone is, that isn’t a smartphone. I have a dim memory of a handset in a base station – is that what that is? :slight_smile:

1 Like

Did a bit of testing my latest iteration of Doze Detect last night and this AM, unfortunately the fact that you are in Airplane Mode, and Google does not update the Status to reflect that WiFi has been enabled, it pretty much ruled useless.
I have to rely on the two RW Status that include the words ‘on WiFi’ as a trigger to turn the screen on (which kills doze)

I am now considering the Extend Home option but I am confused about what a phone is, that isn’t a smartphone. I have a dim memory of a handset in a base station – is that what that is?

Extend Home phones can be any corded or cordless phone that you connect to the ATA. I have connected a Panasonic cordless phone with 4 handsets. These handsets act like extensions of my RW cell phone. All phones ring with an incoming call and can be answered on any of them. The home phones can also call the cell phone or vice versa. All phones share the same phone number and Voice Mail, which can be retrieved from cell or home phones.


I could, of course, leave the cell radio enabled while at home. It just seems a needless waste of battery, since my cell signal here is only usable maybe 50% of the time. Even when the phone can hold a cell call, the other end usually complains of bad call quality. So, I generally have made a habit of going WiFi-only while at home. I was hoping T-Mo’s signal would improve when the town built a new water tower in eyesight view of my driveway last summer. But, apparently, none of the three dozen antennas on it are for T-Mo.

Message an
Expert customer