After Updating Android, No Internet on Moto G4

What phone do you have? Moto G 4
What plan are you on? Clear Coice w/ 1 gig
Does your plan include data, or just talk & text? Includes data


Issue Description

I updated Android and since then get no internet. I live in an area with almost no cell service so connect through WIFI which normally works great. No longer. I get a message on my phone Connected, no Internet. I have cleared caches checked and reset modems and routers, called my ISP...

I tried chatting w CoreyK who suggested I open a Help ticket. I did. On Friday Grant W. said he would help me but on Saturday now, has not gotten back to me.

Support can take up to 48 hours to reply so just give them a little more time.

What version of Android are we talking about here? (And do the support people know this?).

Have you tried booting into safe mode to see if an app is causing the problem?

Android 7.0. And yes I tried Safe Mode…

Best to wait for your reply from support then.

Will do. TY.

Hi @dans.go5la7,

Thanks for bringing this to our attention. We’ll be very interested to know if others who recently updated their G4 to Android 7.0 are now having trouble connecting to Wi-Fi, so I hope others will chime in here (and open a ticket) if they notice the same issue.

I’ve reminded our team that you are still awaiting a response.

Hi southpaw- Just to clarify, I think I can text and make calls through
WIFI, but cannot connect to the internet. (My uncertainty is based on the
fact that I get a little cell service, usually not enough to make calls,
but it does work once in a while…) Thanks for following through on this…

Thanks @dans.go5la7, Our technicians are looking at your ticket along with a few others I found that, on the surface appear similar (Wi-Fi connectivity issues after the android update) to see if there are commonalities.

If you want to be sure whether your calls and texts are going through Wi-F or cell, you could put the phone in airplane mode, then turn Wi-Fi back on. This will disable the cellular radio altogether, leaving no room for doubt.

In Airplane mode with WIFI turned on I cannot make calls or text…

Then you know they are sneaking in over cell for the time being.

Have you tried turning off Bluetooth, and/or testing in Safe Mode to see if either allows the phone to connect reliably to Wi-Fi? (Both are for troubleshooting purposes only, not meaning to suggest you’d then have to operate that way forever if it worked in that state.)

I have tried both without success.

Thanks, that would suggest it’s not an app conflict.

I’ve added some notes in your ticket, to try to prevent them from duplicating my questions. I noticed that a technician was researching your case as I was typing.

Do you remember if you cleared the system cache after the Android update? (Not asking you to repeat steps - I didn’t see verification in your ticket that it was something you had done.)

1 Like

Yes I did…

Thanks, @dans.go5la7,
I’ll update your ticket with that info, as well.

Not sure this will go through without WiFi.

Any progress? Is there a way to reject the recent Android update?

Best,
-Dan

Hi @dans.go5la7,

You cannot back out of an Android update. It looks like they were waiting for this screenshot in your ticket, I didn’t realize that. I’ll add it there since you’re having connectivity troubles.

What phone do you have?

Moto G4

What plan are you on?

1 gig/month

Does your plan include data, or just talk & text?

Data, talk & text

Issue Description

Over the past few days, I have not been able to get my phone to connect properly with Wifi. The WiFi screen may say “Connected,” but the notification screen says “Connected to cell” and I can’t get any web pages to load. I just downloaded the last system update recently – maybe that’s related to the problem?

Hi @subbobmail,

I moved your post into this topic because the issue sounds the same. Having it in the same topic will help us look for commonalities.

Have you opened a support ticket? I’d like to alert our technicians that you appear to be having the same problem as @dans.go5la7.

1 Like

Here’s a wrinkle – as soon as I uninstalled Opera VPN from my phone, it worked perfectly.
I installed a different VPN app on my phone, and it stopped working.
So basically it seems like I can’t get a VPN app and the phone to play nice together. This is worrisome – I’d like to keep my data secure…

Message an
Expert customer