AirWatch APP Issue on Moto X (2nd Generation)

apps

#1

My employer uses AirWatch and AirWatch Inbox App to allow me send and receive MS outlook emails via my personal Moto X (2nd Gen). I have had this function for over a year without any issue until recently (last week or two), my employer’s IT software says that my phone is NOT encrypted and therefore NOT security compliant. I showed my employer’s IT that my phone’s security setting clearly indicated that my phone is indeed encrypted. However, after the IT Dept tried numerous different ways (including un-installing the AirWatch App and reinstalling it, and hard-reset my phone etc). None worked. Our IT Dept contacted AirWatch, and they had no clue why this is happening, and suggested a factory reset. Please help me understand why this is happening. For example, is it because a new OS upgrade caused this? Also, how can I solve this problem WITHOUT resorting to a factory reset?

Thanks.

LZ


#2

@leiz,

I can’t exactly answer your question about why this is happening, but I can commiserate with you about these employer-sponsored security apps. They can be wonky for sure.

I’m not saying you should do one, but I’ve done factory resets a few times. Since I had good backups of everything I cared about, the restoration process wasn’t really all that terrible. And the phone tended to run better after the reset.


#3

Someone had a similar problem in the thread below (turned out they just needed a screen lock pin). I don’t know that this is your exact problem, but the e-mail and phone number for Airwatch is in the thread. If I were you, I would give them a call. It was a happy day when I uninstalled Airwatch from my phone (my company no longer requires it for e-mail access).

https://forums.androidcentral.com/android-security-talk/479972-lollipop-airwatch-mdm.html


#4

Hi @leiz,

I’m afraid I’m going to second @jimk here. Unless another member happens to use the AirWatch apps, your best bet is likely working with your IT folks and/or AirWatch support.

There have been no recent operating system updates for your Moto X2. I doubt an update to the Republic app on your phone is the issue but you might try uninstalling updates to the Republic app through Google’s play store to see if that makes a difference. Please be aware uninstalling updates to the Republic app may cause your Republic service to degrade, so I’m suggesting this as a test not a fix.

Finally, and for what it’s worth, AirWatch is not well reviewed on Google Play:


#5

Thanks so much, that solved my problem! RW community rocks!


#6

Thanks so much for your help with this! It solved my problem :slight_smile: I went to Settings>Security>Screen Lock>Pin>Require pin to start device. As soon as that was enabled, Airwatch recognized my phone as compliant.


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.