All incoming calls are going directly to voicemail

I have a Motorola G6. As well as the ongoing problem with Visual Voicemail, all my incoming calls are going to voicemail. I just called myself using my Google Voice number. I immediately got my “Leave a message” instruction. All this means that my service has become useless. I don’t receive any calls and everyone has to leave a message, which I don’t see. I have to continually call voicemail to see if I have anything. This has been going on for over a week.

I’ve tried uninstalling and updating my Google Phone app. Then rebooting the phone. This does no good. This is not surprising since the last update was on October 7th. I was told on a Republic Chat session that the latest version of the Visual Voicemail problem started about a week ago.

I’ve also checked to see if I have Do Not Disturb anywhere. If I do, I can’t find it.

  • My question refers only to calls going directly to voicemail, see the entry below from @rolandh for other issues
  • Does this (direct to voicemail) issue occur if you are on WiFi, but have the phone on the charger?
    • Asking to help define the problem area.
1 Like

Hi @7om8rown,

Calls routing to voicemail without ringing your phone would be unrelated to the current visual voicemail issue. You mention this going on for a week. Are you referring to calls routing to voicemail? The visual voicemail issue? Or, both?

Even with visual voicemail not populating on the phone, you should be receiving notifications when someone leaves voicemail. If you’re not receiving notifications, it’s another sign something beyond the visual voicemail issue is going on. When you do dial into voicemail, are there messages waiting for you?

Does this Republic help article help:

1 Like

I realize I have two problems. I receive a notification when a voicemail recording is made, but the visual voicemail tab tells me I have no messages. I then must click on the link to take me to voicemail. I only realized this yesterday. That is when I found I had eleven messages. I can then listen to the messages. The calls don’t show up in “Recents”. It’s as if no one has called. When I was receiving all the notifications about voicemail, I thought they must be robocalls. That was why they didn’t show up in visual voicemail. Only three or four were robocalls.

Yes, it does.

I tried that. It didn’t help. I now only have one problem. I uninstalled the Phone app and unchecked the automatic update box. Hopefully, someday I will be able to check it again.

Everything is still going straight to voicemail. At least now I can see it without calling voicemail.

Thanks, that rules out the phone going into Doze mode, which can cause calls to go to voicemail when a user has poor cell connectivity

Message an
Expert customer