All sound broken on Moto G4+

What phone do you have? Moto G4+

What plan are you on? MyChoice + (3 GB)

Does your plan include data, or just talk & text? Data, Talk, Text


Issue Description

This morning I went to look at something on my phone (I cannot remember which app, probably Facebook) when I heard a weird electronic crackling noise coming from the phone. I pressed the power button to put it to sleep, and that stopped it. I noticed that I was at 26% on the battery so plugged it in to recharge and also rebooted it.

This afternoon I discovered that the sound does not work, at least not in the native speakers. I cannot hear voicemails, podcasts or videos. I cannot hear anything at the other end of the line on a phone call, either. Volume is turned up, that’s not the issue. It’s not on silent mode.

I can hear everything just fine if I plug in my earphones, though.

This is probably a phone issue, not a RW issue, but has anyone experienced this?

Fixed!! Per answers to a question someone else posted a while back (My Moto G4 speaker stopped working - General Discussions - Member Community), I checked the phone in safe mode and discovered the sound worked there. That was a relief to find out it was a software, not hardware, issue. I cleared the cache and that worked!! WOOT! Thank you, RW Community.

5 Likes

Aaaaaand the problem is back. The only thing I’ve done to the phone since getting it to work again was to change the default keyboard back to my Swiftkey keyboard. I’ve uninstalled that, tried to use the phone again, but still no sound.

Now the electronic static noise is happening in safe mode, too. Ack!

Hi @jent,

I’m sorry to see the Moto G4+ is still having the static noise issue. :confused:
You have done a great job of troubleshooting this!

You might try the Device Help app on your phone and run a hardware test of the phones speaker. If you still have issues, I would recommend a factory reset as a final test to see if this is a software or hardware problem.

I did the hardware test, and it told me there was probably a problem with the speaker. I took the phone to a local repair shop yesterday, where they replaced the speaker with a brand new one.

The speaker works intermittently, often with that static sound. To top it off, now the phone battery will not charge! The amount of juice in the battery fluctuated wildly yesterday (0-39-15-43% etc.) but has slowly drained from 19-14% today while plugged into the wall. Although the phone recognizes that it is plugged in (icon shows it is charging, pop-up window saying connected to turbo-charger) the battery health apps show me that it is not charging at all.

You didn’t say if you tried a Factory Reset. That is the last option I can offer in trying to keep your G4+ going. :face_with_monocle:

But If I were you, because of the age of the phone and battery, I would be reluctant to spend any more money trying to fix it if a reset fails as well. It might be time to think about a replacement.

1 Like

I hate doing factory resets, LOL! I have not done it yet, since everything was pointing to hardware issues, not software. I’ll try it before I pull the plug, just to see, but I’m not hopeful.

I actually have started perusing the current phone options with RW to start planning my next move.

Thanks for your help and support!

1 Like

Hi @jent Did you ever solve this issue?

Nope. I bought tools and a new battery online and replaced that myself. I couldn’t see anything wrong with the speaker or its connections (but I’m not a professional).

The new battery works great, anyway. For now I’m holding onto the phone to use as a second camera for livestreaming, or maybe I’ll let my sister-in-law (who only knows Apple) play with it to learn about Androids.

For my everyday use I purchased a Google Pixel 4a and am happy with it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer