Android 12 beta for pixel?

Android beta for pixel is available for public enrollment. I’d like to give it a shot on my RW pixel 4a. I’ve read that others previously ran Android 10 and 11 beta on RW pixels successfully in the past; that there is a risk that calls and messaging will stop working if you remove and replace the sim card with a beta build; and that unofficial builds are unsupported. Does all that still apply to the beta 12 for RW pixels?

If one were to download and use the beta, and something triggered the reset condition that causes RW to check the build number and disconnect service, is it possible to unenroll and revert to the standard build of Android?

A couple years ago the Android 9 beta messed things up for the Republic Wireless users who attempted to use it. You might want to review that help document for reference:

In short, you assume all the risk. Unless you’re a developer, why bother?

1 Like

My understanding is that you CAN roll back but it will require a factory reset of your phone, so that is quite a bit of hassle.

I also understand that Republic will NOT actively support beta versions of android, so you’d be on your own/ fully at the mercy of these forums for “support”.

That said, as someone who personally loves to beta test, I fully get your desire to take the plunge and would love to hear more about your experience should you decide to do so!

Try using google fi I have a pixel 3A and I am running beta 12.
Have had no troubles at all. The new UI is great an what a
difference it has been for battery life in the pixel
I am happy with the up date.

All you have to do is pay 33% more for the base plan and 100% more per GB of data. Pass. I can wait for the actual release of Android 12.

Thats ok .I still use fi. my bill is only $23 -27.73 for 30 day use

Downloaded 12 Beta 2 last night, and, despite no problems with Beta 1, Republic is now flagging my Pixel 3a as incompatible with their network. Oddly enough, data still works, but I cannot make calls or send messages. Any suggestions or rumors of an impending solution?

Make sure the Republic app had all the permissions on, otherwise…
Rollback to Android 11 or wait till the Republic app updates to support that build of android for the pixel.

Compatibility with any Android version does not require a Republic app update. I wanted to clarify this only because I don’t want @Checklist watching for an app update announcement in the hopes that it’ll resolve this issue. In very simple terms, we manage device and OS compatibility through a database the app references, not by data stored and updated in each release of the app itself.

We do not support any Beta or pre-release OS.

@Checklist, please understand some very important points here, and I apologize for the redundancy, but I need to be sure this is extremely clear. Please stick with me, as I’m going to make reading it worth your time:
We do not support any Beta or pre-release OS.
This means:

  1. If you are using an unsupported phone or OS, our Help Team will not be able to offer support. If you have an issue that requires their assistance, they will not be able to assist unless/until you roll back to a stable release.
  2. If you are using an unsupported phone or OS, our service may not work correctly. You are assuming all risk.
  3. If you are using an unsupported phone or OS, you are operating outside of our Terms of Service and RW would be within our rights to discontinue your service. (This is very unlikely, we don’t have a squad watching in eager anticipation for rogue OS use just for the joy of terminating paying customers. However, if there are indications of abuse or negative impact on the networks, this action may be required, and the right is fully reserved for reasons I might very well not have listed, so this should not be considered an exhaustive list of reasons for termination. I am not a lawyer.)

Now, if you have read and completely understand all of the above, and given the conditions you’ve described above - the phone worked until you installed this update - I believe you’ll find that if you refresh the Republic activation (on WiFi, with the active SIM card in place) the phone will be functional again. :crossed_fingers:

2 Likes

I have the same issue with the 4a. Unfortunately Southpaw’s suggestion didn’t work for me (it did allow some previous texts to come through but didn’t allow me to send texts or make calls). If only rolling back to Android 11 didn’t require a factory reset…

When you open the Republic app, does it present the “Bummer, this phone is not compatible” message? That’s what I was hoping to remedy.

If there are actual functionality issues (texting, calling) once that message is cleared up, that would signal there is something about this version of the OS that is genuinely not compatible with our network, and that’s not going to be something a dialer code can resolve.

I am using Android 12 beta 2 on my Pixel 3xl with Republic Wireless.

The Android 12 beta 1 worked great, no issues. I upgraded to beta 2 and things got messy. First, the Republic app started telling me I needed to activate when I tried to dial a number. When I clicked the “activate” button, it would tell me the phone is activated and suggest I restart. This did not fix that issue.

Then I would start seeing the green screen telling me “Awesome, this phone is supported…” It tells me I can buy a SIM card. below that, a link telling me to install a system update so I can use Republic.

None of that works… so, essentially, there are some issues with the Republic app that need to be worked out. I got the same answer when I shared with Republic support… They don’t support beta releases and suggest I revert to a general release.

Here’s what I found to get it working with Android 12 beta 2:

open the Google dialer app
dial * # * # V O I P # * # *

you should see the green screen showing your phone number and it telling you to restart. You can swipe it away (do not restart for now).

If you restart, the Republic app will crash and you will have to do the dial again.

As for SMS, I had to load Republic Anywhere on the Pixel. It works.

I have filed a bug with Google in the beta program for the Republic app. Fingers crossed they will work or encourage Republic devs to upgrade their libraries, etc. and release a new Republic app.

Enjoy Android 12 beta 2. Lots of new things to explore!

2 Likes

When I open the Republic app I get the same message I got before refreshing the activation: it says “Awesome! Your phone is supported by Republic!” But it thinks I don’t have a SIM in and then at the bottom it says I need to update Android. (I ran some diagnostics program earlier and it did recognize the SIM but said the version of Android was not compatible). Following randyp’s advice, I tried a couple more times without restarting the phone and I get the same result with the app, but I’ve now observed that I am able to send and receive phone calls (yay!), just not texts, at least with the regular texting app. Weirdly, I can access the Republic app if I tap the “Restart required” notification and it seems normal and I don’t get the insert a sim message. But I am still stopped by the message if I open the app the normal way.

Thanks, @norag.swjaxb,
I was basing my advice on this comment, which, I thought indicated that the app was giving the “Bummer, this device is not compatible with our service” message.

This just means the OS isn’t supported - typically we expect that to be because someone is trying to use a very old OS or that the presence of our SIM card might trigger the availability of an OS we do support. The error is a bit poorly worded in this circumstance since you’d actually need to “Downgrade” rather than “update” the OS.

If @randyp.3s5xdu is able to provide the link to the bug he filed, so you can “star” it or chime in on it, or so our developers can reference it, that may be helpful, too.

Here is the link to the Android 12 beta 2 Republic app bug. I have not updated the bug to reflect the workarounds I posted here.

https://issuetracker.google.com/issues/190710165

1 Like

The sms app I use does not work with Android 12 beta 2. The app will not receive and keeps saying send failed.

I loaded the Republic Anywhere app and it works. I suspect it communicates to republic sms server using a non-sms method, avoiding the sms brokenness.

Another fun bug in the Republic app: it will keep telling you that it does not have cellular access… even though it does (and in my case I can connect to wireless and it does not ‘see’ that I have done that). Just ignore that message.

Maybe it has to do with the introduction of the Internet button in Android 12.

1 Like

Thanks @randyp.3s5xdu,

I’m denied access to it, but I’ll pass the link along to our developers in case they need to reference it.

I am not sure why Google is not letting the issue be publicly viewed.

The issue ID is 190710165.

The issuetracker does appear to let people add comments to the specific issue (even if you can not see the details). https://issuetracker.google.com/issues/190710165

We just rolled back to Android 11 on a non-Republic phone we have because 85% of our apps are crashing, including the Gmail App.

This really isn’t a Republic thing.
Android 12 bugs: Beta 2 introduces some rough bugs- 9to5Google
Apps crashing w/ Android 12 Beta? WebView is the issue - 9to5Google
Here’s how to fix constant app crashes in Android 12 beta (androidpolice.com)
(1) [Pixel 5] Android 12 Beta - Almost all apps crash. : android_beta (reddit.com)
How to Downgrade From Android 12 Beta to Stable Android 11 Build (wccftech.com)
If apps keep crashing w/ Android 12 Beta, WebView might be the issue - News Break

And so on and so forth.

Message an
Expert customer