Android Messages not Working Properly

What phone do you have?
Moto X Pure
What plan are you on?
My Choice
Does your plan include data, or just talk & text?
Includes data


Hi All!

I’ve been having problems using the Android Messages app for about the past month, with the past week being at it’s worst.

It started with group MMS threads that I was a part of, where maybe if there was a lot of chatter at once, I would get a notification that there’s a “New MMS to Download”. Then I’d have to find the message in a separate private conversation and touch to download into the group message.

Lately, it’s been bogging down to the point that I get the “Messages isn’t responding” message with the options to close, wait, or send feedback, while having a handful of messages to try to download because it failed the first time. All this while it’s taking upwards of 30 seconds to send my own texts, regardless of if I’m on LTE or WiFi.

Now it’s all the point where I don’t receive the messages at all for hours after it’s been sent to me. I would go to send a text, then all of a sudden I’m receiving messages left and right from the previous night :frowning:

Any tips or troubleshooting would be appreciated.

Hi @garenc!

Was it working fine a month ago? First, I would recommend clearing the messages app cache. Go to settings, then go to Apps, and then select Messages. After that, tap storage and hit the “Clear cache” button. Try it and see if it works better. If that doesn’t work, try to uninstall updates and return it to the original state. Be warned that you may lose your text history though. First, open up the play store and go to the messages app. Then tap the three vertical dots and de-select “Auto update”. Next, go to Settings, then Apps, and then choose Messenger. After that, tap the three vertical dots in the upper left and tap “Uninstall updates”. Let me know if it starts working after that.

It’s been probably happening since March or April, but it’s been snowballing over the last few weeks.

I just cleared the cache, I’ll see if that improves things. If not, I’ll try the other steps.

Thanks!

Just checking in to see if Android messages is working any better for you. Have you seen any improvement?

Slight improvement after clearing the cache, but it has slowed back down again. The app just updated today, I believe. But it still doesn’t appear to fix any performance issues.

I will try deleting/archiving older text threads to see if freeing up some space will make any difference, then move onto rolling back the updates.

1 Like

I’m having exactly the same problem! Clearing the cache doesn’t help. I’m reluctant to restore the app to its factory settings because I don’t want to lose the conversations that I’ve had.

I’m using a Moto E4. Any help would be appreciated.

Hello, I am also having the same issue. I’ve been experiencing it for quite a while. Tried clearing the cache, which helps temporarily (a matter of minutes.) I also deleted the app data, which help temporarily. I don’t see where I can roll back updates or I would try that.

Hi @tommyr.khd1o8 and @garenc!

Open up the play store and go to the messages app. Then tap the three vertical dots and de-select “Auto update”. You can then uninstall updates by going to Settings, then going to Apps, and selected Android Messages. Then tap the three vertical dots in the upper right and tap “uninstall updates”. To save your texting data, download Republic Anywhere and swap it to the default texting app. Your texting history should show up on the Anywhere app. You can then uninstall updates to the Anywhere app.

Hi @mb2x,
I’m pleased to report that your suggestions have worked out so far. Like the others, i was hesitant in not wanting to lose my prior text conversations. But downloading Republic Anywhere is a good backup to keep the messages intact. I’ve disabled the auto-updates for Android Messages, and uninstalled the updates. It’s currently at it’s default state and it works fine. At least i can tell that my sent messages are going at a much faster rate. I’ll continue to monitor over time, and slowly update the app. Thanks for all your help - and I should’ve done these steps months ago!!

1 Like

Awesome! I am glad it worked for you! If you ever have any other issues, don’t hesitate to come back here and let us know! We are here to help.

I’m having the same issue, but I do not have the option of uninstalling updates on the Galazy S7. Any other options?

Specifically I cannot do this:

Then tap the three vertical dots in the upper right and tap “uninstall updates”.

Faced the similar issue, while the same working fine with my friends. No idea what’s wrong, did you get any way out?

Regards,
Daniel Smith https://putlocker.ooo/
https://viamichelin.onl/

Hi @daniels.yqo78a and @artjoslyn!

Your best bet (if it won’t let you reset it to factory settings), would be to uninstall it and download an older version here: https://www.apkmirror.com/apk/google-inc/messenger-google-inc/ . You probably want to choose a version that was around when it was working fine for you. Make sure you choose the right version for your Android version. You may also need to find and enable the setting “Allow apps from unknown sources” if your phone is not on Android 8.0 or higher.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Message an
Expert customer