Android Oreo support: Pixel and Nexus

#1

I am just curious to know if it is safe for me to download and install Android Oreo on my Pixel XL. Will my RW service be interrupted if I do so at this time? Any idea how long before we are able to download without any issues?

0 Likes

#2

Hi @josephi.xjjdpw

I wouldn’t recommend it until RW gives the go ahead. certanly wouldn’t want to go first. :slightly_smiling_face:

3 Likes

#3

An active phone may work [there are people running the beta right now] but one will not be able to activate a phone until Republic updated it’s build table [white list]

2 Likes

#4

So in retrospect I should have listened to this advice. I took an Oreo update and now the only feature not working is sending SMS/MMS when I am on a cell connection. I opened a ticket to see if anything could be done and unfortunately I would have to downgrade with requires unlocking the bootloader. The version of the Pixel I have was a refurbished one that apparently was previously with Verizon. Which means that is not possible to do.

In summary…do not take the Oreo update if you get it until the carrier testing phase is completed. I hope it is soon.

0 Likes

#5

I am able to send and receive SMS on cell on my Nexus 5x. I didn’t test SMS in Beta and now have the regular build. I’m mostly on WiFi, so it’s not something I would have noticed for a while. I haven’t seen any other issues.

0 Likes

#6

Was this a developer preview or the official build?

0 Likes

#7

An active phone may work [there are people running the beta right now] but one will not be able to activate a phone until Republic updated it’s build table [white list]

I would not encourage anyone to run an beta versions of Android because of potential issues it could cause.

0 Likes

#8

I just tested on the official build. I had the last Beta version before that, but I can’t tell you whether SMS worked there or not. I’m on WiFi most of the time and don’t receive a lot of SMS messages.

0 Likes

#9

I am using build OPR6.170623.011

According to what I have found that should be an official build for the Pixel XL. link to build number definition

I was enrolled in the Dev Beta program, and once I got that final update to Oreo removed myself from it and was not pushed any previous builds.

0 Likes

#10

encourage or not there are some the have been running it, that’s all I said

0 Likes

#11

Don’t know if this is related but I also have a message I cannot get rid of in my notification tray.

Mobile Carrier
Mobile data has run out
Tap to visit the Republic website

The app sending it is CarrierDefaultApp. I am on the Clear choice $15 plan so only WiFi data. When I click the link the browser just times out from too many redirects.

0 Likes

#12

I’ve seen a few friends that have installed the developer preview versions of Oreo with the latest version of the Republic app (3.14), and they don’t seem to be having significant issues with calling and/or messaging. This is this limited anecdotal experience.

We are prepping version 3.15 of the Republic app (it’s undergoing testing now) that will have integration with the new features in Oreo such as notification channels, and will include our full suite of testing of calling and messaging on Oreo.

Ideally, we’d suggest that you wait until 3.15 of the Republic app is available before upgrading to Oreo. If you’re not on the Android Developer Preview program, the timing should be pretty close to work out naturally.

Unfortunately, we didn’t get any advance notice of the Oreo release date other than what Google publicly shared, so the Monday release of Oreo was as much news to us as it was to you. We’ve been working to get 3.15 out quickly based on the Android developer previews, but Google released quicker than we anticipated.

If you are on a production version of Oreo (build id starts with OPR6) and are having a problem with calling or messaging, I’d suggest to open a RW ticket.

We will soon be updating the supported device list with the Oreo builds of Nexus/Pixel, so new activations will be possible.

4 Likes

#13

Thank you for that information. It was the answer I was looking for. I will admit that I should have waited, but did not understand that Republic Wireless was not ready for the upgrade. So when I did it, I didn’t think it would be an issue. Hopefully the updated republic app will fix the issues I am having.

I am on a production version of Oreo (Build number starts with OPR6) and I have a ticket opened, but they have been unable to help me as they do not have any support for Oreo at this time. I even talked with Google support, but they were unable to fix the issue either.

I am debating if a factory reset and clean install of the OS would fix anything, but I am unsure if I need to go to that measure. I will wait for the updated RW app and if it still persist, I can open another ticket I guess.

0 Likes

#14

For what it’s worth, I logged into Google and had Oreo pushed the day it came out to my Pixel. I read that joining the Beta would indeed push out the released version of Orio (build OPR6 like you have).
I have had no issues with it at all on Republic

0 Likes

#15

I did the same thing. To see if I have an issue could you answer a few questions for me.

Pixel or Pixel XL?
What build number do you have? (does it end in .012 or .011)
Do you have a cell data plan?
Do your text messages (SMS) go through when sending from android messenger when you are only on cell?

0 Likes

#16

Sure!

It’s the smaller Pixel (not XL).
Build # is OPR6.170623.011
i’m on the 1GB plan RW plan
I have no issues with sending or receiving SMS or MMS via cell OR wifi, however I’m using Republic Anywhere and not Android messenger.

Hope that helps

0 Likes

#17

Thanks. The only difference I have is that I am using Android messenger and do not have a data plan. I will try moving to Republic Anywhere. If that does not work, it could be that I can only send text with data right now, which should fix when the carrier settings are updated.

0 Likes

#18

I use wifi over 95% of the time and MUST use it for phone calls at home in San Francisco because the cell signal is horrid in my apartment. If you do-do the Factory reset let us know if it helps! I usually do one every-time a new OS drops but I have not done it yet with my Pixel (just the over the air install over Android N).

0 Likes

#19

Yeah I am on WiFi a lot, but at work the VPN on our WiFi network blocks calls and text so I cannot use it here.

I also found on Reddit some people reporting that their are some carrier LTE issues which could explain why I also do not have the LTE symbol showing next to my signal strength anymore. That could be fixed when the carrier testing finishes though.

I tried Republic Anywhere and it still was not working so it is not an issue with the messenger app. I am thinking it is either the carrier issue or it did not install correctly during the update. I think I will go with the factory reset to at least start with from a fresh start on the new OS.

0 Likes

#20

So just a heads up to everyone, a factory reset did not fix the issue. At least the OS install is now clean. Just need to wait for the official support from Republic Wireless and the carrier they use to support SMS with no data.

0 Likes

Message an
Expert customer