Anywhere app not working - messages from contacts appearing in different threads

What phone do you have? Samsung Galaxy S10

What plan are you on? My Choice

Does your plan include data, or just talk & text? All 3


Issue Description

Received a text from a friend today that appeared in a thread with my husband. (She only texted me, it was not a group text. It was her name but in a thread that was just my husband). When I replied, the response went to my husband. When I tried to start a new text thread to her, it kept pulling up my husband’s thread. I checked contact info in my address book–it was correct. I deleted the text thread with my husband, deleted my friend’s contact info and created a new contact. Now if I try to text her, it pulls up another person’s thread (again, not a group text–just a thread with a totally different contact). My husband now comes up in a thread with a different person (his name & pic, but the rest of the thread is not him, nor was it a group text). If my husband texts me, his texts come up under that person as well. I can’t message anyone because I don’t know who the message is going to. The best way to describe it is like the lines are crossed. I restarted my phone, cleared the cache in the Anywhere app, deleted several text threads, deleted and recreated a contact and nothing has helped. Also some recent texts in various different threads are missing (they were missing before I cleared the cache–and it’s anywhere from messages received 2 days ago to 1+ weeks ago). I tried switching to the Google Messages app. It looks like the full threads are in tact in Google Messages and contacts appear to be correct, but I can’t actually see if it works because the keyboard doesn’t come up for me to send anyone a message.

I have also synced contacts. It hasn’t corrected the issue either.

Is anyone else having trouble with Anywhere? Or Google Messages?

Hi @nancya01,

I’m sorry to see no one replied to your question about Republic Anywhere.

I’ve only seen the issue you’ve described when the Anywhere app was installed on a phone that was not activated with Republic. I’ve never seen it before when Anywhere is being used on the Republic phone.

If uninstalling and re-installing the Anywhere app from this phone doesn’t resolve the issue, then please switch to the Messages app by Google (not the one by Samsung.) You will not have this issue with that app.

Message an
Expert customer