Anywhere app on Mac OS 10.11.6 sign in error

What phone do you have?
Moto G5S Plus
What plan are you on?
My Choice + 1 GB
Does your plan include data, or just talk & text?
Includes data


Issue Description

Cannot sign into Anywhere app on Mac 0S 10.11.6 El Capitan. The error says “An unknown error occurred. Please check your internet connection and try again.” My internet connection is working fine. I’ve had this issue for over a week. I’ve reinstalled the Anywhere app. and still get the same error. I’ve checked for updates and it shows that I have the latest Version 2.5.12 (2.5.12). Please Help!

Hi @paulh.t2x861,

Is the Mac in question your personal Mac and, if so, is the network it’s connected to your network or does it belong to someone else? I ask because, generally, the error message you see is caused by attempting to run Anywhere on a computer connected to a network running a proxy server. Quoting from Republic’s Anywhere FAQ:

  • Issue : When using a computer that is connected to a network with a proxy server, you may experience an error message indicating “An unknown error has occurred. Please check your internet connection and try again.”
  • Workaround : No workarounds are available at this time.

Hi, yes it is my personal Mac. I have not changed how it is connected to the internet via my internet service provider CenturyLink.

Hmm, no apparent changes makes this more difficult to diagnose. It’s theoretically possible CenturyLink made changes. I’d like to take the network out of the picture if that’s feasible. By that, I mean is it possible for you to connect the Mac to a network other than CenturyLink to see if the problem persists? Obviously, if your Mac isn’t a laptop that’s not easy to do. We might use your Republic phone to temporarily set up a hotspot. For that we would need to know the brand, model and generation of your phone and whether your plan includes cell data?

I set up a hotspot and was able to connect my iMac to it but was unable to get any data.

Do you know if you have cell data ion your plan?

I installed the anywhere app on my Windows 7 computer and it works fine. I wonder if there was a Mac update that is causing an issue.

Working fine with CenturyLink or using your phone as a hotspot? El Capitan is actually three Mac operating systems old but without knowing the generation (year) of your iMac, I can’t say whether updating the OS might help.

Working fine with Windows 7 on CenturyLink. I can’t update my Mac OS because the 20" early 2009 is not compatible.

Good Morning @paulh.t2x861,

My apologies for not responding sooner! Indeed, there is both an early and late 2009 iMac. Apple really needs a better naming convention but I digress. :slightly_smiling_face:

Since Anywhere works on your Windows 7 PC while it’s connected to CenturyLink, that would seem to rule out something with Republic’s servers or your Internet connection. Therefore, it’s time to look further at the iMac. If you look at System Preferences -> Network -> Advanced -> Proxies; do you see anything interesting there? This is a shot in the dark but you might try adding the following string under “Bypass proxy settings for these Hosts & Domains”:

all.pro.mqtt.igate.nocell.io:443, s3-1.amazonaws.com:443, auth.republicwireless.com:443, clients.l.google.com:80, api.republicwireless.com:443, api-d.republicwireless.com:443, cognito-identity.us-east-1.amazonaws.com:443, mobileanalytics.us-east-1.amazonaws.com:443, sts.amazonaws.com:443

These are the domains one typically needs to whitelist for use on corporate networks. I realize you’re not on a corporate network, however, it’s worth a shot.

If that doesn’t work, you might try deleting the Anywhere preference files. You’ll find those at Users -> Your User Account -> Library -> Preferences -> com.republicwireless.anywhere.plist and com.republicwireless.anywhere.helper.plist. Before deleting those files, I suggest killing any running Anywhere processes using Activity Monitor. To do so, open Activity Monitor (it’s in the Utilities folder), search for Anywhere, then Force Quit any instances of both Republic Anywhere and Republic Anywhere Helper.

If neither of the above help, we’re pretty much out of non-destructive options. If necessary and you’re up for destructive (to Anywhere messages stored on the Mac not the Mac itself or to messages on your phone), let us know.

1 Like

Hi Roland,

No need to apologize. I appreciate you taking time to assist me. I tried all your suggestions, but the same error occurs. I’m ready to go nuclear.

FYI, I already performed the rest local content.

Very well, then here’s the nuclear option. Trash the Anywhere app and the Anywhere preference files again. Then, do this: How to Clear Republic Anywhere Cache on a Mac – Republic Help. Please ignore the references to app version 1.5.6 and macOS Sierra. Next, reboot the Mac. Finally, reinstall Anywhere from scratch.

It occurs to me, if you haven’t already tried rebooting the Mac, do that before going nuclear. You might also power cycle your modem and/or router before declaring war.

Still not working. Do you have a larger nuk?

I’m afraid I do not. Do you know how to create another user account on the iMac? I’m curious to see if Anywhere will run properly in a different user account?

I logged into the guest account and after giving admin. rights to connect to the Republic internet sites, the same error occurred.

Did you install Anywhere in the guest account or is it still being run from your user account? What I’m driving at is to set up an additional user account, then install Anywhere in that user account. If it works there, something is corrupted in your user account.

Hi Roland, I set up another admin. account and it still give the same error.

Happy New Year!

Hi @paulh.t2x861,

My apologies for the delayed response. At this point, I’m out of ideas. In theory, things should be working. Though a couple of generations old, according to Republic, macOS 10.11.6 meets Anywhere’s minimum system requirements and we’ve done everything possible (short of nuking the Mac and reinstalling macOS).

A Happy New Year to you as well, sir!

Hi Roland,

No need for apologies. Thank you for your time and effort put into trying to resolve the issue.

Is there any support provided by the developers of the Anywhere app? Do they have a Beta test version that would give a more diagnostic error report to reveal the root cause of the problem?

Thanks again for all your help!

Message an
Expert customer