Anywhere BETA on Linux


#1

I want to try the community supported Anywhere BETA for Linux.

This article provides 2 links–one to join a group, and another to a discussion where presumably the download can be found. Both links fail.

Did this project die?


#2

Hi @Troywolf,

We did some re-organizing of the Community last week as we start to prepare for a new phase of Anywhere Beta and some other Beta groups that might need to exist in Community.

I’ve moved a very nice write-up of the Linux installation instructions to our Tips & Tricks category, here:

Edited to add: I’ll also submit a request for that help article to be updated. Thank you for pointing out the dead links.


#3

I still use the Anywhere Linux client and it still tends to be more stable than the Windows client (although things have improved greatly on Windows!) The work put into it is impressive.


#4

Thanks for pointing me in the right direction, @southpaw. Seems like you’ve done that several times for me! Thanks also to @Burusutazu for posting the detailed instructions in Tips & Tricks. I run Ubuntu 16 and the app installed and is working well it seems.


#5

Did not even know that there was a linux version. Really there is not. You have made a version for Debian/Ubuntu/ versions.

You would need a rpm based client for the other linux users.


#6

Wouldn’t it be fair to say, there is a client for most Linux users? Debian/Ubuntu would seem to have the overwhelming lead in Linux market share: https://w3techs.com/blog/entry/ubuntu_became_the_most_popular_linux_distribution_for_web_servers.


#7

You quote “market share” of web servers for a locally run client app?

There is no reason they can not include a rpm based client as well as debian.


#8

I quoted, what I was able to find. I’m reasonably certain the overall percentage of folks running Linux on the desktop is minuscule compared to commercial operating systems like Windows and macOS.

How do you know this?


#9

You are correct, a majority of regular Linux desktop users run Debian/Ubuntu and it’s derivatives. Combined Ubuntu/Debian hold a combined 64.2% market share as of 2016.

I believe this number will undoubtedly be lower as of today because of popular newcomers such as Solus and Antergos, but not by much.

Edit: Oh, wow, I didn’t even look at the article @rolandh linked and I end up quoting directly from it!

Another good website to keep an eye on trends and market share is distrowatch.


#10

How do you know this?

There are “commercial” versions of linux dektops. They will gladly take your money just like Microsoft and Apple.

Because I have packaged both. If they are running on debian based systems it should be fairly trivial to run on Red Hat based systems.

So instead of debating the merits, defending Republic, or whatever you are trying to do simply let it go.

I made the comment in this thread to plant a bug in the Republic Wireless ear that they are not offering it to all linux users.


#11

Rather than package Anywhere for for RPM would a Snap or Flatpak not be more universally accessible? I would love to see Anywhere expand to more users.


#12

You expressed your opinion as I’m free to express mine.


#13

I tried to install Anywhere Beta on Linux (Ubuntu 14.04.5 LTS) yesterday and it failed with an error during the signature verification. Perhaps the key error was “There is no public key available for the following key IDs:1397BC53640DB551”. Is beta for Linux still available? Are the instructions for installing the same as those posted in July? Thanks, - Wayne -


#14

Years ago, I wanted to install a software package (in Ultimate Edition, a Ubuntu derivative) that wasn’t in my repos. I did some searching and found it packaged as an .RPM. I didn’t feel like spending an hour figuring out how to compile it, myself, from the source code - so I looked in my repos and discovered a tool that was created to allow people to install .RPM files in an Ubuntu-based distro.

You might look around in your distro’s repositories (et cetera) to see if you can find a similar tool that would allow you to easily install .DEB files in a distro that uses .RPM packaging.

I remember now, the tool is called alien - and I’m pretty sure it could convert packages in both directions. Try installing that and using it to convert the .DEB.

If, for some reason, you are unable to successfully install the package via alien… Is the source code available?

(Moderator’s note: Signature removed in accordance with Community Guidelines)


#15

14.04 is not supported


#16

Thanks. I had checked the supported Ubuntu versions, and somehow thought the one on this PC was included, but you’re right, what’s supported is 15.04 and newer. I’ll try to upgrade to 16.04 sometime, and try again.


#17

If you don’t mind waiting I’d suggest waiting till April for Ubuntu 18.04LTS. That way you don’t have to worry about updating for a long time.


#18

For anyone interested in using this on Solus (and maybe other distros?) I downloaded the .deb package, opened it with Archive Manager and extracted the ‘republicanywhere’ directory from the /usr/share/ directory in data.tar.xz to the /opt directory within Solus. When I executed the Republic Anywhere app from the directory it worked perfectly. I tried with several versions and the beta.
If I knew packaging in Solus I would submit it to the repository, but until I have time to play with that figured someone might make use of this information.


#19

If the source code were available, we could compile it on whichever version of linux (and, possibly, FreeBSD) we like. Assuming that we are available to meet the dependency requirements, of course.


#20

A post was split to a new topic: Question about signatures removed from topics