Apps are randomly crashing and phone will restart on it's own

What phone do you have? Moto G5 Plus

Does your plan include data, or just talk & text? 1 GB data


Issue Description

Different apps suddenly started popping up saying XXX has stopped. I've checked my storage (have plenty of space), uninstalled last update on Android System Webview (that seems to be when the problem started) and now that app shows disabled. I've cleared the cache on all apps and finally as a last resort, I did a factory reboot of the phone. None of this has helped, apps still pop up saying they have stopped!

This issue (if it is the same issue that impacted nearly everyone with Android) was resolved by an update from Google. Do you have all the apps on your device updated? If you open the Play Store and go to My Apps and Games does it show updates available?

1 Like

I had done that before I did the reboot. I just checked and there is an update for Google available, I will update it and see if it helps. Thanks

The Google update did not solve the problem. Do you think the Android System Webview app could be the problem? If so, it shows it is disabled and won’t let me uninstall and reload or enable it. It had been suggested to me that that was the app causing the problem.

Hi @dollyc ,

Yes. It needs to be running.
See if this article helps. Here are some things to try including clearing the cache and data of the Play Store App. Give this a try and let us know if you can get the app going again. :slight_smile:

I read the article and did everything suggested except downloading the APK for updating the app, I couldn’t seem to get that to work. BUT, when I pull the Android System Webview app up in the Play Store, it says it is Disabled. One of the comments under reviews said that once the app is disabled that there was no way to enable it again. I don’t know how it got disabled. Any other advice?

When you look at Android System Webview on your phone does it look like this?

Did you try deleting its storage cache and data? :thinking:

Mine looks like this.

Please try this (admittedly this is a guess) :nerd_face:
Go into your settings/apps and disable the Chrome app, then go back to the Play Store and see if you can update the WebView app or if it lets you re-enable it from the phone. :crossed_fingers:

2 Likes

Good guess!!! That actually worked, now to see if it fixed my problem…a little time will tell. Thank you so much!

1 Like

No, my phone still says the app is disabled and I’m still getting messages that apps have stopped. I’m ready to get a new phone!

You said:

Did you mean a Factory reset? Where it brings the phone back to the factory settings? If so, after your signed in… what happened next? Did anything update via the Play Store?

Yes, I did a factory reset. I started getting the error message as soon as the phone started booting back up. I just double checked, System Webview shows installed while Chrome is disabled but went back to disabled when I enabled Chrome again. There is an update for Chrome in the Play Store but it wouldn’t update…just tried it again and it did update this time. I’ll see what it does now!

I’m still getting the error messages that apps have stopped. I read an article that said Android System Webview was not necessary with Android 7 and above because it was built into Chrome. I checked my husband’s phone, he still has Android 7 and it shows System Webview being disabled on it, he hasn’t had any issues.

From what I can find on the internet… I agree the Webview on Android 7 and 8 can show as disabled.

Can you post a screen shot of the error?
Is this a Play Store error?
Are all apps updated?

If no… see what happen when you boot into safe mode:

All apps are updated. Here are 2 error messages that just popped up. I get them on various apps over and over! Plus, my phone keeps restarting on it’s own.

My last 2 thoughts (That I can think of right now) :thinking:

  1. Have you rebooted since you and I have been working on the phone?

If yes…
2. I can only suggest a second reset.
Once you get signed into your Google account go right to the Play Store and do any updates. (Don’t restore any other apps for now)
If all goes well, sign into the Republic app and see if that stops all the rebooting and problems. :crossed_fingers: :crossed_fingers:

Thanks for your help. I’ll work on it again tomorrow. I’m surprised that I haven’t seen anyone else on here saying that they are having this problem, so frustrating!

Hey @dollyc! I just happened to stumble across this thread and read through it, and I see there was an update to the Chrome app since you last posted here (2 small updates actually, on the 24th and 26th). Have you updated your Chrome app since then? And if so, have you still been having this issue with apps crashing or has that stopped? The new Chrome app versions are 90.0.4430.82 and 90.0.4430.91, if you want to verify whether you’ve gotten either of those updates

2 Likes
Message an
Expert customer