Are RepublicWireless and RelayPro passwords truly decoupled?

What phone do you have? Moto E 2nd gen
What plan are you on? Republic Refund and RelayGo/RelayPro
Does your plan include data, or just talk & text? Talk, text, and data


A while back, I changed my relaypro password to be different from republic wireless password, as per instructions from republic. (I believe this was because Dish did not buy the relay business)

On Tuesday of this week, I signed into my account at https://relaypro.com. My relaypro password did not work. On a whim, I tried my republic wireless password, and it worked. I then changed my relaypro password back to its desired value. I became suspicious when I noticed that the password-change dialogs took me to a republicwireless URL, but I continued and I was able to access my relaypro account.

Now today, I tried signing into my republic wireless account. My republic wireless password did not work. I tried my relaypro password, and it does work.

I haven’t seen this symptom in recent discussions related to account sign-in problems, so I thought it might be useful information…
Thanks,
Andy

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.