Are your calls coming in on Cell or going to voicemail when your phone is sleeping?


#22

I ran the test again last night, this time with the S7 plugged into the charger. The test call rang through hence the WiFi connection was not dropped.


#23

I have a Moto Z Play. There is an advanced wifi setting called “Keep Wi-Fi on during sleep”. This setting doesn’t seem to have any effect. Whether set to “Always” or “Only when plugged in”, wifi appears to disconnect about 1 hour after sleeping (according to ping). I tested incoming calls 5 times today after wifi stopped responding. 4 of the 5 incoming calls rang w/o any problems. Once, the incoming call went to voice mail. On a second attempt, the phone rang.


#24

@williams here is the test of the Moto Z Play you were looking for.

@kyleh.bxadi2 thanks for the great test. Which router do you have? Your phone seems to be behaving as Sean described earlier in this thread. When you first wake it up after it stops responding to the ping do you see a hollow arc, a solid arc, or the triangle that Williams is seeing? I ask because this might explain why your calls are ringing the phone but his aren’t.


#25

This is the first I have seen this thread. I will attempt to test this in the morning on my Moto X pure.


#26

I’ve tried this three times today, just leaving my phone - a Moto E (1st gen) - asleep for 2+ hours each time.

1: Call woke my phone immediately but went straight to voicemail, anyway.

2: First call did not wake phone and went straight to voicemail. Second call woke phone and I was able to answer.

3: This time, I put my phone in Safe Mode first, then let it sleep. Call woke phone and I was able to answer.

Does the success with Safe Mode implicate one (or a combination of) my apps, or is this just too small a sample set to make a determination?


#27

I ran the test again last night in order to try to narrow down the problem. This time, I uninstalled a couple of my of apps (Amazon Instant Video and Netflix).

This test was of a Moto E (1st Gen) running Lollipop, in Airplane mode with WiFi turned on, Bluetooth turned on, NOT in Safe Mode and NOT plugged into the charger. I let it sleep for 8+ hours and called from a separate line. It woke up immediately and allowed me to answer the call.

I wonder if the Amazon Instant Video app or Netflix app doesn’t get along well with Lollipop?

I will try to test this further to determine whether the phone is now working consistently.

This has been a bit of a headache since I upgraded to Lollipop, so thank you, billg, for suggesting this test!


Any apps that need to be exempted from Doze?
WMM vs. QOS, Advantage and Disadvantages
"Voice calls only" error message; something may be blocking access to the Republic Wireless Network
How to: Set up a reminder to turn wifi back on
#28

Thanks for running these tests. Here are some factors that might explain what is going on:

  1. When the phone wakes up we know RW has found the phone hence it had not lost its WiFi connection. The fact that it didn’t ring suggest an issue with the phone. This could very will be an caused by an app or even the need for the recommended weekly restart. The one test in Safe Mode does suggest an app but Safe Mode does require a restart. The phone set to Do Not Disturb will yield this result as will the ringer set to ring only for priority callers which is quite commonly the problem with ringing is intermittent.

  2. When the phone neither wakes up nor rings the phone might have lost its WiFi connection or a router setting might have kept the packets from reaching the phone. With my ASUS router the router setting that caused this was WMM-APSD which is enabled by default and needed to be disabled to fix the problem.

Yes, that is a small data set. With the router issue mentioned above the phone would ring on the 3rd or 4th consecutive call.

When I was dealing with WiFi disconnects I stumbled into a way to tell if the phone was losing its WiFi connection without even having to call it. There is an app call Doubletwist I use to sync my iTunes playlists with my phone. Doubletwist comes in two parts, a player that is installed on the phone and an app for my PC that locates both my music and my phone. The free version syncs via the USB cable, the paid version syncs over WiFi too. I have the paid version that behaves like this:

Doubletwist is configured to present a sync option whenever is finds my phone on WiFi. When it finds the phone a dialog box pops up on my PC. I dealt with WiFi disconnects and reconnects when I was testing a G4+ when the 3.0 phones were first available. I couldn’t see the disconnects but I could see every reconnect because that dialog box would appear on my PC screen. RW dealt with this problem with an update to the 3.0 Republic app but by the time the fixed app was released I’d already returned the G4+.

When that problem was present I knew it was exclusive to the 3.0 phones because I had a 2.0 Moto X (2nd Gen) equipped with Doubletwist alongside it that was not reconnecting. The problem did appear when I got my S7 but the fix arrived shortly after that. If you want to spend a couple bucks on what is a very useful feature for those who use their phones for music stored on their PC (I have more than 4000 songs) it is also useful for troubleshooting WiFi disconnects.


#29

My test was successful. Rang through without issue.

Edited to add: I have left it on airplane mode for most of the day and I got two texts that my wife sent to by after I turned airplane mode off.


#30

coreyk wrote:

My test was successful. Rang through without issue.

Edited to add: I have left it on airplane mode for most of the day and I got two texts that my wife sent to by after I turned airplane mode off.

Wow, that’s strange. I wonder why the didn’t arrive when you were on WiFi.


#31

Here is the results of a test conducted on a Moto X Pure as Device Under Test (DUT)

Pretest conditions:

  • Reviewed the morning news (on WiFi) while plugged into charger
  • 8:40 (approx) removed from charger and relocated DUT to my office
  • 10:44 (approx) Call from another Republic phone received after DUT was idle for ~2 hours
  • Series of screenshots taken from video
    • SC1 shows incoming via Cellular Network with the OWA (Open White Arc)
    • SC2 shows Status change to SWA(Solid White Arc) verbiage still shows Cellular
    • SC3 shows immediately after Answering call (Timer =00:00) Status shows both SWA and OWA
    • SC4 shows notification SWA with OWA Handover avail from Cell to WiFi
    • SC5 shows 54 seconds into the call right after the phone apparently Auto handed over from Cell to WiFi
    • SC6 shows Status line after the Handover occurred

Summary:

Problem: (**idle device, **not on charger … does not wake on call via WiFi from Republic) but the Cell call goes through and then the phone auto changes to WiFi. CDR shows the call as Cell.

This can and has been duplicated multiple times, this time the sequence of events was captured on video to allow a more thorough review.


#32

They arrived after a turned cell back on.


#33

Wow! Nice work. I wonder what the significance is of having TWO solid white arcs as seen in the last screen shot. I saw this a couple of days ago on my S7. I also wonder how calls coming in on cell and then switching to WiFi impacts Bandwidth’s revenue considering how a few pennies change hands whenever a switch is used. @seanr what do you make of Bens report and my questions?


#34

coreyk wrote:

They arrived after a turned cell back on.

Yes, I gathered that, but you were in Airplane Mode with WiFi on before that and I’d have expected those text messages to have reached your phone before leaving Airplane Mode.


#35

OK, just confirming. Not sure why. They came two hours later after sent. Might test more.


#36

The 2 SWA or 1 SWA + 1 OWA are in the status … and they match what is shown in the expanded Notification (example sc3/sc4 … I didn’t grab a Screenshot of the Status bit it did turn to 2 SWA in the timespan befor my SC5)


#37

I’ve had my phone on SideSync for a while and have been texting with a granddaughter. I just happened to notice the hollow arc so I called the phone twice. Phone was NOT sleeping. Both calls came in on cell.

Then I opened and closed the Republic app. Arc remains hollow.

WiFi shows Connected:

I toggle WiFi off and back on and get a solid arc:

I call the phone again and now it comes in on WiFi.

Raleigh, we have a problem. Ping @seanr


#38

My understanding of the new app is that the behavior you are seeing is that the Republic app, through its diagnostics, is seeing your network as not adequate for WiFi calling with this behavior. Personally, I think that is how the app is intended to behave.


#39

Yes, that is what I understand too, but I thought it did that periodically. My WiFi was working just fine but the Republic app didn’t recognize that until I toggled WiFi off and back on. Were it not for one of these rare periods when I had a one cell bar the calls would have gone to voicemail for no good reason.


#40

The Republic app is basically a show of registration(SIP & MQTT). It re-registers on a consistent basis (hourly) and when new WiFi connections happen. If an hourly re-register fails (phone and server cannot talk), we then retry several times. The retry interval steadily expands until we only try each hour, unless WiFi re-connects. WiFi suddenly getting connectivity is not a trigger (can’t be). So if your WiFi stays connected but we cannot get to the server for like 15 minutes or so, then we would not try again for an hour or until you cycle WiFi.

We could keep trying WiFi registration to keep you connected but if we kept failing your battery would drain.

I think I have explained this in the past but it needs repeating.


#41

I don’t have cell coverage at my house and leave the phone in airplane mode. So, I only see a solid arc. Normally, when I wake the phone, I swipe down to see notices. The phone usually shows that wifi is disconnected briefly and then updates to show the connected state. I have DSL with an older Westell Modem and an older Linksys WRT54G router. I did have to monkey around with the modem settings to get incoming calls to work reliably (when the phone was awake). That is discussed here. Thanks.