AT&T Smart wifi

While trying to use my internet providers app to connect my phone to their wi-fi hot spots I get a message that “This Item isn’t available on your carrier”. Its the AT&T Smart Wi-Fi app. Is this something that you can fix so that I can use something i pay for? Thanks in advance

Hi @charlesm.juhuof,

The app developers determine the availability of the app. According to AT&T’s documentation on the Smart Wi-Fi app,

It’s available for all AT&T Android smartphones running version 2.2 or higher.

Could this possibly be the app you need?

I did a search for the Global Network Client on my Moto G 3rd Gen and could not find it. Does show up on a windows based google play store search, however I get a notice it is incompatible with All my devices.
I am running 5.1.1. Would love to figure out how to access the hot spots due to an upcoming trip.
Thanks again Southpaw!

The Play store listing for the Global Network Client app indicates that it requires Android 6.0 and up.

image

You may want to check with your ISP to make sure that’s the right app, and whether they have any options or resources for devices running older Android builds.

1 Like

Been on with att for 2 hours, 5 different agents and still no joy. Maybe i just need to buy some data from Republic…

Maybe there will be public Wi-Fi where you are going. No need to buy the data until you know you need it.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer