Bad Wi Fi signals but phone still insists on using Wi Fi instead of cell


#1

I have a first generation Moto G and recently have been using it in a location with very erratic wi fi reception. But when I make calls or receive incoming calls the phone attempts to do it over wi fi. The result is sometimes being unable to hear the other party or at best having a lot of dropouts in the conversation. My only recourse has been to disable wi fi when making calls and calling the other party back after disabling wi fi if it is an incoming call. I thought the phone was supposed to always switch to the best signal for me. Does the fact that my wifi signal change confuse the phone? Is there something I can do about it?


#2

Hi @ronl.pnf7y3

Sorry for the late response.

Could you check to ensure your RW and RW Telephony apps are up-to date?.

Your should also review the troublehooting section of this document…
Make and Receive a Phone Call – Republic Help


#3

Thanks for the response.

My phone says the app version is “up to date”. What else is it that needs to be up to date?

I looked through the linked document and made sure that “background data” was enabled. Since I am able to make cellular and Wifi calls, the other parts didn’t seem relevant. My problem is in weak Wifi areas when the phone chooses to use the Wifi but the calls have poor to no reception. That is when I need to switch off Wifi and try again.


#4

Still no suggestion of an answer. However I can say that a Moto G5 plus with it’s call blending works just fine in my situation. Now how to make my MotoG first generation behave correctly.


#5

You state that you have very erratic WiFi … do you have any control over the router (even just the ability to power off/on)?


#6

Did you have the Republic app settings set correctly.

Open the Republic app and select the gear icon. Under Advanced settings make sure you have “Allow manual handover” checked; “Enable handover on networks” checked for your WiFi network; “Handover to WiFi when appropriate” checked if you use this feature.


#7

I’m afraid not. It is a public WiFi.


#8

They were all checked except for “handover to WiFi when appropriate”. I just checked it and will see if that helps.

Thanks for the suggestions.


#9

Unfortunately the problem persists. Dialing out, the Moto g chooses WiFi. If I’m lucky I get a bad connection which goes dead for a few seconds then comes back on cell. In a worse case scenario it stays with a very garbled WiFi for quite some time before switching to cell (after a few seconds of dead time).


#10

As there are always a few readers that will see this thread and think ‘me too , thats what I have’ … so here is a pointer to WiFi 1st - Maximize your WiFi/Router - Community Guide
This provides a mini primer on WiFi and some things that users can do to improve their environment


#11

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.