Battery Status not accurate

What phone do you have?
Moto G5 Plus
What plan are you on?
3.0 Call and Text Only
Does your plan include data, or just talk & text?
Talk and Text Only


Issue Description

Wednesday morning I noticed my phone had only charged to 40 something percent. I figured it came unplugged over night or something and didn’t think much of it, other than bummer my phone probably won’t last all day. However my phone did last all day. I charged it Wednesday night and Thursday morning it was only 38%. I noticed the percentage stayed at 38% most of the day and then finally started decreasing in the evening. I plugged it in at 10% and it now says charging and that it is at 0% two ours later. I believe the battery is likely fully charged, but the indicator is just messed up. And suggestions on how to fix it or another app to monitor the battery? Thanks in Advance for you help.

Hi @brookeg!

Have you tried rebooting the phone?

Yes I power down normally this morning and this evening while it was at 0% plugged in, I did a hard reboot

Ok. I am going to recommend that you use your phone until the battery dies. Use it until it turns off tomorrow and then plug it in and let it charge up completely without turning it on (just leave it on there overnight). Hopefully that will help recalibrate it. You could also use a battery calibration app, but I dont know how good those actually work.

Hi @brookeg,

Some additional steps to calibrate the battery are here:

If those steps do not help, the battery has probably begun to fail.

I’m also having a similar issue. I purchased my Moto G5s Plus in February 2018. In the past 2 weeks the battery appears to drain during charging, often getting to below 15%. When it is unplugged, it bounces back up, never to 100%. Previously it would bounce to 99%, but this week it only goes to 98%. I’ve cleared the cache and restarted it, but I’m really afraid to let it go to 0% and charge while off. My last Moto became increasingly more difficult to charge if it dipped below 20% after about 1.5 years of regular usage.

Thanks, this seems to have helped. Time will tell!

1 Like

Awesome! Thanks for coming back and giving us an update!

In my case, it did not help :frowning: I let it go to 0% then plugged it in and let it charge. After 2 hours it got to 48%, after 3 hours it dropped into the 30s%. I unplugged it and turned it on, and it bounced up to 91%. I finished charging it while it was on to 98%. It is also draining faster and faster as this gets worse. I’m going to submit a ticket to Republic to see if this is a hardware failure issue. (Hopefully since it’s less than a year old, it’s covered by warranty.)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer