Battery woes after moving - Moto Z Play

Hi All,

I moved from Pittsburgh, PA to Orlando, Fl recently. I have a Moto Z Play that I activated in 12/16. In Pittsburgh, my battery was still lasting 36+ hours between charges, obviously depending on usage. In Orlando, my battery is lasting 6-8 hours and it seems almost not dependent on usage. I’ve gone from a fully functional phone with excellent battery life to a corded phone because I basically have to keep it plugged in all the time.

I went to a ubreakifix location and had them run a battery function test on it. The battery still has 89% of it’s original capacity. So it’s not a bad battery, unless there can be things other than battery capacity that can impact… battery capacity. They wouldn’t even replace a battery that still has that much of its original capacity.

I’ve tried safe mode. Same battery discharge time (and slope of line) in safe mode. So it seems to not be an app issue.

My last security patch was on 2/1/18 and the battery was fine until 4/20/18 so I don’t think that update caused the issue. My kernel version says it was 2/22/18, not sure if that’s the last update to the actual phone or not. But still, it’s almost 2 months before the battery life started acting wonky.

I’m currently thinking it might have to do with the network? The Moto Z Play is a GSM only phone, right? I’ve checked the coverage maps - everything looks okay, but I’m at a loss.

What say you smart RW people? Do I need to ditch the phone and get one that is GSM and CDMA? Do I need to do something to tell RW that I moved? Is there something else I can try? Help please!


Hi @katherineo.p4c5g2

One possible cause of the problem you describe is an old-ish battery that is working harder to stay in contact with the cell network where you moved.

Do you have WiFi at home now? If you do and are going to be home for a while today, put your phone in Airplane mode but then turn WiFi back on. Leave it that way for 6-8 hours. See if your battery charge lasts longer.

Thanks - I’m running that test now. I do have wifi at home.

I think you’re on the right track, I’ve been seeing some orange (I think more than in Pittsburgh) in the cellular network signal bar.

Well, it looks like the battery usage remains the same, even in airplane mode with wifi turned on. The slope of the line is identical to the new poor battery performance.

So I guess that means it’s not a network thing? I’m at a loss.

It also shows 42% of battery left but only 5% battery usage (2% screen, 1% phone idle, 1% Android OS, 1% Android System.)

This makes me think it has to be a battery issue… but the battery capacity is fine??? Any next steps?

Hi @katherineo.p4c5g2,

One of the benefits of a GSM SIM card is that phone will not typically drain the battery trying to find a cell signal like it will with a CDMA SIM, so I think we can rule that out as a cause, and your airplane mode test verifies that.

It’s possible the battery needs to be calibrated, as it appears what the phone’s reading of the battery’s state is different from the actual state. Steps to calibrate the battery are here:

1 Like

Thanks, I’ll give the recalibration a shot. I need to let the battery drain again so I probably will not have results until tomorrow. Thanks for the next suggestion to try!

Oh my gosh. I was just re-thinking through all of the apps I have. I didn’t install any of them on the date when this issue happened. However, I did install Snaphot (Progressive Insurance monitoring app) a few weeks before and it was inactive until my policy started… when I moved to Florida.

I will try the battery recalibration. If that doesn’t show any results then I will try to put Snapshot “on hold” for a few days to see if there is any impact from that app not monitoring anything (assuming that actually happens when you put the app “on hold.”)

1 Like

My hunch is that it’s the Snapshot app. Progressive would be far more interested in getting thorough, accurate data on your driving (and other) habits than on sensible battery management on your phone.

After the battery calibration, I would suggest you go in the Settings > Apps, find the Snapshot app and “Force Stop” the app for a period of time to see if battery drain lets up. And, check Settings > Battery to see if there is anything revealing there.

Well, I force stopped the snapshot app when I posted earlier and the slope of the battery usage line remained the same. I have not yet recalibrated the battery, since I’m still waiting for the battery to drain fully.

As far as Settings> Battery - the only things of note there is the steep slope of the battery usage line, the mismatch between the battery used and % of battery used by app (see example in earlier post), and the occasional poor signal strength. The poor signal strength existed during this afternoon’s battery drain however, was obviously absent this morning when airplane mode and wifi were on. However, the slope of the battery usage were the same in both circumstances.

Next steps: battery recalibration tonight once the battery drains completely.

Hi @katherineo.p4c5g2

When troubleshooting phone issues I can/usually say SafeMode and ClearCache in the the same sentence.

1 Like

Thanks - just cleared the cache.

It’s possible that recalibrating the battery gave me an extra hour or so of battery usage today. I’m going to try it again tonight and see if it helps anymore.

The slightly extra battery could also be due to force stopping the snapshot app.

Anything else I should try?

Will update with more results tomorrow.

I think patience is good for now. Please do let us know your results.

Well, it appears nothing can stop the unstoppable trend that is my Z Plays battery usage. I’m back to 6-8 hours of battery life.

Anything else I can try?

I may switch away from Republic, as much as I don’t want to, because I can’t convince myself it’s not somehow related to the network. Any last advice/tips/shots in the dark?

Sorry to hear that @katherineo.p4c5g2

Can you go to Settings/Battery and take some screenshots?. (hint: if you tap the graph you can get a History page).

That might give a better picture of what is going on…(pardon the pun).

Hi @katherineo.p4c5g2,

I have noticed on my Moto phones using RW regularly do consume more power and believe it’s due to the the way RW system works. Never have have I seen a drop as significant as you are reporting and wouldn’t think RW is the cause. Switching to another provider in’t going to help if it ends up being a battery issue. Battery tests and calibration don’t always work or report accurately.

Dark shot, have you tried uninstalling the RW app? If it can’t be uninstalled on the Z Play disabling is a way to uninstall the current version. You can then reinstall the current version. This might eliminate a RW app issue.


1 Like

I’m not sure how attaching picture works here. I tried adding several all showing the same battery usage. These compromise a variety of days, conditions, usage, good/bad network connection, and testing (safe mode, airplane mode with wifi, post cache clear, etc.) Hopefully you guys will see something in this I haven’t. Also, if I left RW I would get a new phone to make a clean cut.


Looks like only one picture attached. Here’s another one.

And another. All different scenarios.

I can only compare your battery history pics to my own battery history. But, what catches my eye is the Awake and Screen on time. It appears to me that your phone doesn’t get much down time. Yet, in the first picture, Screen accounts for only 6% of battery usage.

Though unlikely, it is entirely possible that your phone has a faulty battery. If no other reason can be attributed to the rapid battery drain, then it has to be assumed that the battery just isn’t holding much of a charge. This would either be due to battery abuse or a faulty battery to start with. If the phone is still under warranty, I would contact Motorola and argue the latter.

1 Like

I thought that was the issue, but the battery function test came back with 89% of the original capacity. That’s so high the store wouldn’t even consider replacing it.

Is it possible the battery is bad in some way that the function test wouldn’t capture?

Also, this phone was purchased in 12/16, so I’m sure it’s out of warranty.

Message an
Expert customer