BETA: Member support only - How To Install Republic Anywhere On Linux

Some new changes to the main post today.

  • Added hyperlinks to software I mention.
  • Finally added code blocks to the commands so the numbers will no longer be added to the command by discourse.
  • Fixed a broken image. [#5]
  • Updated the apt vs apt-get section.
2 Likes

@jasone.bxqzkv
@Rood15

Okay, so here if the fix for the missing dependency on versions of Ubuntu Linux newer than 17.10.

Install this missing dependency from the terminal.

sudo apt -y install libgconf2-4 

Anywhere should run without any problems after you install that.

Here is a screenshot of it running on Ubuntu 18.04.1.

2 Likes

To switch from beta to stable:

Uninstall republic anywhere using:
sudo apt remove republicanywhere

Then reinstall using the same steps from the guide using the main branch.

3 Likes

Sorry to bring this up again, but I was just curious if packaging the Anywhere app for RPM was still on the roadmap? If not, I might start a Fedora COPR repo (unofficial of course) for it in the mean time, assuming RW doesn’t mind.

1 Like

Hi @emiljt,

I’ve not heard anything new from our developers on Linux since the last time we checked in with them on that question. Linux development is something of a side-bar project for that team, and sometimes other priorities have to take precedence.

I see no reason for you not to take on such a project, if it’s something that interests you. We’ll just need to be clear, as we’ve tried to be all along on the Linux use, that it’s not “supported” - meaning our help team cannot assist with issues on Linux. It’ll pretty much be a matter of our Linux users helping one another.

Hi,

I am using Slackware rather than something Debian/Ubuntu based. I recognize that this is not supported in any way, but I would like to download the .deb, unpack it, and see if I can get it to work on my machine. Is there a URL available to download the .deb that can be reached from wget or a browser (in other words, without using apt)?

Thanks in advance.

Simply use wget or your distribution’s equivalent on the deb files link in the guide.

Hi,

What link is that? The only links I see are links for apt sources and the key. They don’t point directly to the .deb package. Perhaps I am missing something. Anyway, I got it by installing Ubuntu in an LXC container and downloading it with apt, but it would still be nice to have a plain link.

I can report that this seems to be working fine on Slackware, with one hitch: it seems to be looking for a file called /var/lib/dbus/machine-id’ (note the trailing single quote). I’m not sure if this is an error, as I have a file called /var/lib/dbus/machine-id with no trailing single quote. Once I copied /var/lib/dbus/machine-id to /var/lib/dbus/machine-id’, the app started up and works fine.

As far as i’m aware there is no direct link to the .deb file. Using wget then installing the app was the only way I was aware of obtaining the file.

EDIT:

After some digging I found the link to download the Debian package, the file can be found here.

http://files.republicwireless.com/public/apps/anywhere/debian/pool/main/r/republicanywhere/republicanywhere_1.5.9_amd64.deb

I also discovered that someone had made a Arch Linux installer for Republic Anywhere! You can find information about it on the Arch package website.
https://aur.archlinux.org/packages/republicanywhere-bin/

12/18/2018 Changes:

  • Added AUR (Arch User Repository) link.
  • Added Debian package source.

Thank you for the link! I have made a SlackBuild (Slackware packaging script) for it, tested it, and it is working. I may submit it to SlackBuilds.org, which is kind of analogous to the Arch User Repository but for Slackware. If I do and it is accepted, I will update this thread.

1 Like

I’ll add that to the original post when you post it here.

Slackware repackage is here:

http://slackbuilds.org/repository/14.2/network/republicanywhere/

1 Like

I have a working RPM that I’ll be adding soon.

1 Like

Provide a link or post and I’ll add it to the thread as well.

Was a link to a working RPM ever provided/posted anywhere ?

Sorry, forgot to post something :confused:

Here is a link to the RPM I used.
https://drive.google.com/file/d/1pWrahbxwjeoR4Xg4V73ot1eaVVdFfOhl/view?usp=sharing

For reference here are the commands I used. I don’t believe I had to clean up anything else, but I could be forgetting something…

alien -r -c -v [name_deb]
rpmrebuild -pe [name_rpm]
1 Like

Thank you.
I’m having trouble getting to run, but it does install.
Likewise the windows version says invalid exe format, but I’m trying…

Thanks to a tip from Burusutazu, I ran Anywhere from the terminal and saw what the program was missing, that prohibited the program from starting when I clicked its icon.

I just reinstalled Anywhere, since it previously seemed useless to keep it installed. I ran it from terminal and got this response:

republicanywhere: error while loading shared libraries: libgconf-2.so.4: cannot open shared object file: No such file or directory.

I checked Synaptic for libgconf-2.so.4: and it found nothing. So it seems that 1) I don’t have it, and 2) Synaptic doesn’t have it either, or at least under that name.

I did an online search for libgconf-2.so.4 and, after another search, found that it needed gconf2. So I had Synaptic install that and then ran republicanywhere from the terminal. republicanywhere popped up just like it knew what it was doing! I logged in and it worked!

So I logged out and then logged back in using the icon to start the program. That worked too. So Thank you for your response. That led me to the answer I needed to have it working now.

So, if you’re finding that clicking the Anywhere icon doesn’t start the program for your Linux install, try this as a possible solution.

Thanks again for your reply, Burusutazu. I’m a happy camper now that I can use Anywhere in Linux Mint 20 Cinnamon.

5 Likes
Message an
Expert customer