BETA: Member support only - How To Install Republic Anywhere On Linux


#21

I had a hunch you would bring good news.


#22

Man, you put me on the spot! I had to!


#23

Sorry! I promise I didn’t ask that to put you on the spot.


#24

I deal with big Telecom all day ordering circuits. So nice to deal with a super responsive team in the business. Thanks for the update I’ll be on the lookout for a future rpm release, or maybe flatpack?


#25

Here is a two screenshots of Anywhere working on Elementary OS Loki. (which is gorgeous btw)
Fresh off the press today since I finally got around to putting it on my dev boot.


If anyone is worried about the numbers shown all of them are short codes or spam numbers.


#26

For anyone interested in using this on Solus (and maybe other distros?) I downloaded the .deb package, opened it with Archive Manager and extracted the ‘republicanywhere’ directory from the /usr/share/ directory in data.tar.xz to the /opt directory within Solus. When I executed the Republic Anywhere app from the directory it worked perfectly. I tried with several versions and the beta.
If I knew packaging in Solus I would submit it to the repository, but until I have time to play with that figured someone might make use of this information.


#27

I actually had planned on trying this but I never got around to it. It’s great to know that it just works. One of the benefits of electron I suppose.

I’ll take the time to try this on other distros this weekend and will update the guide with the screenshots and info.


#28

That would be great! A few notes from my experience:
I tried 1.5.6 through latest beta and settled on 1.5.8. All worked reasonably well. I am on Solus 3 using the Budgie desktop installed on a Toshiba chromebook 2.

  • To switch RA versions I had to replace the republicanywhere directory in /opt and delete the Republic Anywhere directory in .config (may not be necessary but seemed safer)

  • I did not try the calling function on the latest versions.

  • Of course I had to manually enter the menu option, map the icon etc using Menu Libre

  • I settled on 1.5.8 because later versions did not have ‘show’, ‘preferences’ on right-click on system tray

  • clicking on the system tray does not ‘show’ the window by default but I dont know if that is specific to how I installed or just the way the linux version works.

I’ve been using for about 1 week and have had no issues with texting or syncing, etc. Thanks everyone for the great work!


* Kudo & Win! *
#29

Republic Anywhere is working nicely on my Linux Mint 18.3 system. However, It doesn’t startup automatically when I login. Also, the preference setting for launching on system startup is grayed-out. I tried adding an item to my startup application system settings but the app still doesn’t startup – I still have to manually launch it. Is there an open issue with getting the app to startup automatically?


#30

This is standard behaviour across the various distributions. Startup appears to be handled on a per desktop basis. So on Pantheon the startup launcher (Cerebre?) handles all startup apps.

Take a look at the arguments launching the program to see if there is anything that looks a bit wrong. Although I don’t recommend having it as a startup item since it has a tendency to launch before the network connects and tells you your offline.


#31

I put in a 30 second delay on the Startup Applications control but that didn’t help. It seems my startup application launcher is having heartburn “at startup” … see following syslog items below.
However, when I select the Anywhere item in my Startup Applications control and click “Run Now”, it starts up just fine.

Mar 6 20:31:06 lilnuxmint cinnamon-session[32539]: WARNING: t+0.04368s: Could not parse desktop file /home/cabjlb /.config/autostart/republicanywhere.desktop: Unrecognized desktop file Version '1.1’
Mar 6 20:31:06 lilnuxmint cinnamon-session[32539]: GLib-GObject-CRITICAL: t+0.04376s: object CsmAutostartApp 0x1132f80 finalized while still in-construction
Mar 6 20:31:06 lilnuxmint cinnamon-session[32539]: GLib-GObject-CRITICAL: t+0.04378s: Custom constructor for class CsmAutostartApp returned NULL (which is invalid). Please use GInitable instead.
Mar 6 20:31:06 lilnuxmint cinnamon-session[32539]: WARNING: t+0.04379s: could not read /home/cabjlb/.config/autostart/republicanywhere.desktop


#32

Try just having it launch with the command line argument republicanywhere instead of the desktop file.


#33

Sweet! That worked. Okay, now is there a command line argument to make run without actually launching the display – just running backgrounded until I get notified of new messages?


#34

There is no easy way to do that as far as I’m aware.


#35

Okay, I can live with that :sunglasses:


#36

[quote=“Burusutazu, post:10, topic:10151, full:true”]
I brushed up on my Linux Mint knowledge and wanted to let you know that Republic Anywhere does not work on Ubuntu derivatives using a package base below 16.04 and Linux Mint 17.1 uses a 14.04.3 base. So even if you got it to start installing it would fail.[/quote]

What’s missing and/or what version(s) of what are too old in the 14.04LTS version of *buntu and its derivatives?


#37

I don’t know, it’s not really started what it’s missing.


#38

If you want to run Republic Anywhere on a non-Debian platform I recommend running Debian/Ubuntu in a virtual machine, installing it there, and moving the application over to the main system. From what I have tested Anywhere will run any platform independently as long as it has the basic dependencies for electron and gtk. (most do).

Anywhere has no ability to self update if you do this, you will have to fire up the virtual machine and repeat the process after updating.

Here is Anywhere running on Solus.

Once installed you can find the Anywhere files under.
/usr/share/republicanywhere

You can find the configuration files (your login, text history, gui settings, ect) under: /home/.config/Republic_Anywhere

If you want to move the folder into your main systems /usr/share folder you will need root privileges.


#40

Which part? I’ll take the time to write a bit more in depth if needed.


#41

So I am on ubuntu 18.04 and have been able to install and get everything into my “apps drawer” but when I got to launch it, nothing happens. I have tried uninstalling and reinstalling and still nothing.