BETA: Member support only - How To Install Republic Anywhere On Linux

Was a link to a working RPM ever provided/posted anywhere ?

Sorry, forgot to post something :confused:

Here is a link to the RPM I used.
https://drive.google.com/file/d/1pWrahbxwjeoR4Xg4V73ot1eaVVdFfOhl/view?usp=sharing

For reference here are the commands I used. I don’t believe I had to clean up anything else, but I could be forgetting something…

alien -r -c -v [name_deb]
rpmrebuild -pe [name_rpm]
1 Like

Thank you.
I’m having trouble getting to run, but it does install.
Likewise the windows version says invalid exe format, but I’m trying…

Thanks to a tip from Burusutazu, I ran Anywhere from the terminal and saw what the program was missing, that prohibited the program from starting when I clicked its icon.

I just reinstalled Anywhere, since it previously seemed useless to keep it installed. I ran it from terminal and got this response:

republicanywhere: error while loading shared libraries: libgconf-2.so.4: cannot open shared object file: No such file or directory.

I checked Synaptic for libgconf-2.so.4: and it found nothing. So it seems that 1) I don’t have it, and 2) Synaptic doesn’t have it either, or at least under that name.

I did an online search for libgconf-2.so.4 and, after another search, found that it needed gconf2. So I had Synaptic install that and then ran republicanywhere from the terminal. republicanywhere popped up just like it knew what it was doing! I logged in and it worked!

So I logged out and then logged back in using the icon to start the program. That worked too. So Thank you for your response. That led me to the answer I needed to have it working now.

So, if you’re finding that clicking the Anywhere icon doesn’t start the program for your Linux install, try this as a possible solution.

Thanks again for your reply, Burusutazu. I’m a happy camper now that I can use Anywhere in Linux Mint 20 Cinnamon.

5 Likes

Hi, I’ve followed all of the steps in your tutorial, and I see the Republic Anywhere app in my launcher but, when I try to start it, it simply does nothing.

I’m new to Ubuntu having started just yesterday. I have an Asus laptop with an AMD-64 and Ubuntu 20.04. Any suggestions?

Try running it from the terminal (republicanywhere) and see if it gives any errors.

1 Like

Thanks! I tried that and got the following error: republicanywhere: error while loading shared libraries: libgconf-2.so.4: cannot open shared object file: No such file or directory

I’m new to unix but studying hard to come up to speed. I appreciate any help you can give.

1 Like

This is a common error on newer versions of Ubuntu/Debian. The dependency libgconf-2-4 is no longer included by default.

You can try installing it from the terminal with the command:
sudo apt install libgconf-2-4

It will require your password.

Republic should work as soon as its done installing.

Hey thanks! By looking at what was missing, I used the sudo apt-get command to find a missing library. Now I have it running and tested using my wife’s phone to send me a text. That worked and my reply from the keyboard did, too.

What’s next? At the moment RepublicAnywhere only runs from the terminal command line. It’s a manual startup and, if I use Ctrl-C at the terminal, the anywhere app terminates. My job now is to get it to launch at system startup as it did when I was running Windows 10. Let’s see if I can do it.

Thanks! I have figured it all out and now have the Anywhere app start up automagically when I log in to Ubunto. BTW, I have an Intel Core i7-6700HQ CPU.

2 Likes

Whats new 8/11/2020:

* Added new instructions for using my brand new installer script.

Something New

After noticing a uptick in users who find themselves installing Republic Anywhere on Linux only to find it will not launch due to missing dependencies I decided to take a crack at writing a script that will simply the entire install process for Republic Anywhere into a single run command.

This script is written in python and the source code of it will be readily available on GitHub for all to see. I also want to stress that this installer script is in no way endores by Republic Wireless and you will be using it at your own risk.

Meet Republic Anywhere Installer

You can find the repository for the installer here on GitHub.

You can find the Initial Release here on GitHub.

Using the Installer

Using the installer is simple, the GitHub repository has instructions but I will releat them here.

  1. Download the republic_anywhere_installer.py file found in the latest release.

  2. Open a terminal, the common shortcut for this is Super+T.

  3. Navigate to where you downloaded the install script. For the downloads folder this would be the command:

    cd ~/Downloads/
    
  4. Run the installer using the following command.

    sudo python3 ./republic_anywhere_installer.py
    
  5. Input your password then accept the changes that the script presents.

  6. Republic Anywhere should now be installed.

As always if you would rather use the official Republic instructions you can still find step-by-step instructions in the original post still.

1 Like
Message an
Expert customer