Bizarre Moto Z Play Charging Problem


#1

I have a Moto Z Play that starting having a strange charging issue a few weeks ago.

It is taking the charge, the indicator comes on when I plug it in. But when I unplug the phone it shows that my battery has not increased. If I restart my phone, the battery suddenly is full. This occurs no matter if I use a turbocharger, another USB charger or a car charger.

Yesterday things got worse.

  1. I noticed in the morning I had forgotten to charge my phone the previous night.
  2. I plugged it in around 11:00 am while preparing food for Thanksgiving (It was at 4%)
  3. I unplugged it around 1:00pm when we were leaving, and got a low battery warning. With no time to fool with it, I grabbed my charged and left.
  4. I used the car charger and powered off my phone. Charging icon showed on the screen. I restarted my phone when I got to my MIL’s house and got a low battery warning. Still at 4%
  5. I plugged in my phone at her house, are restarted a few times with no success. Always at 4%.
  6. I plugged it in again, left it alone for while we ate.
  7. Later that evening I unplugged my phone (still at 4%) and got the low battery warning.
  8. I restarted and Wa-La - 99%. 12 hours later I sit here with 89%. The battery will last several days with light use, one day with heavy use.

Any ideas what is going on? Is this hardware or software related?

Is there an app that will tell me the true percentage of battery life left? All I tried just give me the same number.

I have tried retraining the battery by letting it drain all the way and recharging. That doesn’t help.

Moto Z Play
Android 8.0.0


#2

Sorry your post hasn’t gotten any responses in a few days.

Here’s what I noticed on the Moto website
https://support.motorola.com/in/en/solution/MS113707

If you are within your 1 year warranty period, it might be worthwhile to contact Moto and see if they are willing to do anything about it.


#3

Thanks,

I think I might try a factory reset first. It’s interesting that it started happening suddenly. It’s clearly not a battery problem. I charges and holds the charge well.


#4

#5

@gcks21a Are you still having this issue?


#6

Yes, I am. I have not had the free time to do a factory reset to see if that fixes it.

So far I just manage it by charging my phone, then re-starting it. I have tried re-calibrating the battery but that didn’t help either. I have tried some apps that are supposed to re-calibrate the battery, but again no help.

I really think it’s software related and not the battery itself. The Android system is not reading the correct percentage from the battery unless I restart.


#7

Except for the green cape…there is no easy way to identify former ambassadors such as yourself…wish they gave you guys Ambassador Emeritus or similar identifiers :slight_smile: Hopefully a future software update kicks your phone out of this mode!