Black screen of death on boot? ADB pushing fresh OS?

My Moto G (1st gen) has been acting weird, closing apps before they finish loading, and optimizing apps repeatedly when rebooted. Now, it’s stopped loading android at all. After the Moto boot logo spins it goes to a black screen and feels warm after sitting for a long time. It’s backlight is on, but it’s unresponsive.

I want to do a hard wipe back to factory but I have data to retrieve, photos mainly. I was hoping I could use ADB to push an android system update and hopefully un-brick my phone but I don’t know where to get that file safely…can it be downloaded?

Can anyone help me figure out how I can fix my phone? I’ve tried clearing the cache in recovery, and tried accessing the files in ADB, but the connection is closed because my device isn’t rooted.

ANY help is greatly appreciated. I need this phone back on ASAP.

Try Clearing the Cache :

Clear the Android System Cache

Clearing the system cache can help to resolve issues and improve performance of your phone by removing temporary files associated with the Android operating system. None of your personal files or settings will be deleted. If your phone isn’t running as smooth as it once did, try clearing the system cache by following the steps below.

  1. Turn off your phone and remove any charging cables.

  2. With the phone off, press and hold both the Volume Down and Power buttons at the same time for 2-3 seconds, then release both buttons.

  3. The phone will display different options. Use the Volume Down button to scroll through the options to “Recovery” and press the Volume Up button to select it.

  4. The phone will display the Motorola logo, then the Android figure lying down with an exclamation point with the words “No Command” underneath. Press and hold the Power button and tap the Volume Up button.
    Note: If you wait too long to perform this step, the phone will reboot and you’ll need to start the process again.

  5. The phone will display additional menu options. Use the Volume Down button to scroll to “Wipe cache partition” and press the Power button to select it. The cache wipe will begin immediately.

  6. After the Cache Wipe is complete, the menu items will reappear, with “Reboot system now” highlighted. Press the Power button to select it. Your phone will restart.

Thanks, I’ve done that about 6 times now, to no avail. furthest it boots is moto logo, spins the logo, then black screen.

With any luck, your photos are at Google Photos - All your photos organized and easy to find . I think all that’s left is to do a Factory Reset .

thankfully, they are. I won’t really loose much most likely, I can see the file tree when I choose “update from SD card” in the recovery menu, so I can look at what I’m loosing. That’s the most irritating part…I can SEE the file system, I just can’t access it.

I’ll look one more time for a Motorola system .zip I can update the OS with, and just wipe it. I was planning to soon anyway because it was acting so funny…

Do you know if google photos will see my phone being reset and then delete images from the cloud?

Thanks for your help. If anyone knows where I can get the moto G OS update (any) I’d love to get it.

Your photos will remain in the cloud as long as you don’t actively go in and delete them. I don’t know that you’ll be able to find a system image file for a Republic Wireless ROM. Hopefully you won’t have to, and a factory reset will get you up and running again.

Bit the bullet and did a factory reset of all data, and sadly it performs exactly the same. Cache clearing and a full factory wipe do nothing, even after repeated attempts. I believe the firmware has a corruption…and I desperately need 4.4.4.

I’ve read that if I downgrade to 4.4.2 (files seem available) I can brick the phone (won’t improve situation), so I’m really hoping someone from RW or a savy tech can reach out. I don’t want to buy a new phone…

You might have a look at Need to Flash on Republic Wireless Firmware for Bricked Moto G 1st Gen (out of warranty) .

OMG…THANK YOU!!!

THIS WORKED!! I used the directions in one of the links that are in that post, combined with a firmware I found online (not sure who linked me to it) and adapted the directions to that file. Took me about 10 minutes once I had the right firmware!

These are the instructions: [GUIDE] Moto G - Restore stock firmware | Moto G

I used this android 5.1 firmware build: Republic Wireless US - https://www.androidfilehost.com/?fid=529152257862672545 (Newer Build)

From this page on xdadevelopers: [INDEX] Moto G [Falcon][Peregrine] Factory F… | Moto G

I’m very grateful for your help. If it weren’t for the community and your help I’d be out at least $200. Sadly RW didn’t have any files to send me but luckily the internet helped. My phone is working and currently downloading all my old apps. Thanks again.

-Andrew

Message an
Expert customer