Block WiFi Calling By Network

I’m all for WiFi calling and on most networks it works great. But I always have problems on my work network. After I manually hand the call over to cell it’s fine. Is there a way to permanently set calls to cell when I’m on my work network? If not, I guess my only solution is to submit this as a feature request.

Hi @purple_sunday

You can just forget your Wi-Fi work Network on your phone.

Settings/WiFi/ select the network you want to remove and forget.

Thanks, but I’d still like to use WiFi for everything else I do on my phone. So I’d rather not go that route.

Hi @purple_sunday,

Republic offers no way to block only calling on WiFi networks. You could simply turn WiFi off, however, that will force all phone activity including Internet access to cell.

An old method for accomplishing what you’d like to do is cached by Google here: http://webcache.googleusercontent.com/search?q=cache:dY6_HU-3JbkJ:www.moderndefrag.com/2015/01/disable-wifi-calling-republic-wireless.html/&num=1&hl=en&gl=us&strip=1&vwsrc=0. The original website hosting that content is offline. Fair warning, I’ve not tried the method with a newer 3.0 Republic phone.

You might also achieve the same effect by asking the IT folks at work to block outbound traffic on UDP port 5090, which is needed by Republic for call setup.

Thanks for the info and tip. I tried installing that app, but already uninstalled it for two reasons:

  1. I’m not sure that app works well the 3.0 plan and/or my phone. The app keeps crashing on incoming calls.

  2. Again, it’s just not a very convenient solution. I’d have to manually open the app and turn on the firewall at work, then turn it off when I’m not at work to take advantage of the benefits of WiFi calling. I checked to see if a widget might be a simpler solution, but unfortunately there isn’t one.

I appreciate the help, but I’ll chalk it up to no real better solution than turning WiFi off before making a call or trying to manually handover an incoming call before I have problems.

Unfortunately, I don’t have enough clout to make that kind of request with IT. :slight_smile:

FYI - I may have figured out a solution. I’m already an AutomateIt user. So I just added 3 new rules - turn off WiFi when there’s an incoming call while I’m connected to my work network, same rule with outgoing calls, and enable WiFi when the call ends (with that rule only enabled after either of the first two rules are executed). It seems to be working well. Hopefully this will continue to be a viable solution.

2 Likes

I tried the Mobiwol approach that was suggested, my Moto X Pure (like all 3.0 phones) does not include the Republic Telephony, as its function has been incorporated into the standard 3.0
I tried multiple iterations/variations of blocking WiFi on the Phone App, blocking Background data etc and was never able to get the Cell Call/text WiFi data state to last more than a min or so
So my guess is something like @purple_sunday suggested above or implementing his flow control with Macrodroid which many are already using to overcome the Doze sleep problem

1 Like
Message an
Expert customer