Blocking someone in messenger and they still ring my phone


I keep getting text messages urging me to download something that does not download from They ring my phone all the time, and they are unsubscribable.

They don’t have a phone number, so reply with unsubscribe does not work. I found the site online, but they won’t take my phone number to unsubscribe. I sent them e-mail to unsubscribe, and they never responded and I’m still getting dinged all the time.

I never subscribed to this service, so I finally blocked them in messenger, which resulted in them still ringing my phone, but now me getting only the notifcation ring, but not keeping the message.

As far as I can tell, this is something to do with the weather. When I look at installed apps, there is no weather app shown, but the default homepage (Moto x4, Android 9) has a weather app on homescreen.

So, does anyone know how to either make a block really work, or how to get rid of this particular text spammer?



Sounds like a local news station (WDRB in Louisville, KY) text alert system:

You can try unsubscribing at the link above.



Thanks, that is the place I attempted to unsubscribe from before, and sent them e-mail w/o response.

When I attempt to unsubscribe, it just says I have to fill in phone number, despite phone number being filled in.



in Messages by Google one can block a sender option (really just archives it but you never see it)

open up the message thread from the contact you want to block

tap the 3 vertical dot menu in the upper right

tap People & options

there will be a block option (with the number being block listed)

1 Like


I did that. It hides the message chain, but still allows the sender to ring my phone with notification, so not really blocked as far as I can see.



So you’ve tried entering your number and selecting Republic Wireless as your carrier at, and never receive a code by text? Which phone do you have? If it’s a legacy phone, I suppose the message could be coming in to the underlying routing number. Or perhaps the subscription is an e-mail to text subscription. In that case try in the e-mail field of the link above. Or, you may try turning off the Email to SMS feature on your phone:



Thanks for helpful suggestions: really thought the email2text was going to do it, since the text sender address is an e-mail account, but the unsubscribe doesn’t take my phone with republic text either :frowning:

Also, Allow SMS messages from e-mail isn’t checked, so I have no idea how this e-mail address keeps spamming me.



I also tried contacting the company doing the spamming:, but they do not respond to e-mail.

At a guess, the former owner of this number signed up to service, but was on a different carrier, and this is why unsubscribe does not work for me.

What I don’t understand, however, is why a blocked user is allowed to ring my phone.



Just saw I didn’t say: yes, I tried many times unsubscribing at that link. At a guess, the former owner of this number subscribed with a different carrier (or that page is just broken, no way for me to tell)



I’m pretty much out of ideas. You might try contacting them at:

Mail: WDRB Media
624 West Muhammad Ali Blvd., Louisville, KY 40203
Phone: 502 - 584 - 6441



Hi @clintw.ta0o7k,

I’d like to give something a try, but I’ll need you to unblock the number to see whether you receive the 5-digit verification code.



i’ve blocked & unblocked to try various stuff, so what do you have in mind?



Is it currently unblocked?



OK, it is currently unblocked.

1 Like


Thanks, if you receive the 5-digit code, please let me know what it is.



I have received nothing



Ok, sorry. I guess that is one more thing that didn’t work. I think you’re going to have to get a live person at the agency that is doing the sending to intervene in all their automation and make it stop.



Do you know why block doesn’t stop them from ringing the phone?

That continues to be what confuses me: block seems to be useless.



have you tried turning off the notification for that contact (or making silent the contact)
to do this the contact needs to be made unblocked in Messages by google, open the thread and tap the 3 vertical dot :dots: go to details and then Notifications.
here you can turn off the notification, set priority, change sound (to silent)

the main reason it ring though it the app processes the notification before the block instructions



OK, this seems to be what I was needing (will have to wait for bad weather to confirm)!

I don’t really care if they send me texts, as long as it doesn’t ring my phone.

Do you know if I turn this off this way, and then re-block, if it’ll still ring, or will my “don’t ring” pref (set while unblocked) still be applied while blocked?

Many thanks!


Message an
Expert customer