Bluetooth device not connecting

moto e4. when i go to setting it say bluetooth not connected . so i go to bluetooth and the on button is on. below it says paired devices bluedriver. and below this it says no bluetooth deviceswere found.then on the home page when i open blue driver it says not connected.

Hi @nickf.tezg0v!

I’ve had trouble with Bluetooth devices before. They can certainly be finicky!

One thing you can try (that’s worked for me before) would be removing the Bluetooth device from your phone and then re-pairing it. Try that and see if it works. If it pairs, try turning the Bluetooth off and back on and see if it connects automatically (to make sure it’s going to pair in the future).

I hope that helps!

1 Like

Here is something that I previously suggested for a user,
Here is something that ‘fixes’ a lot of things … clear cache of the app. This is not straight forward, but I have only tested this on a Moto X4, and it is based on info that I have cobbled together by combining some Google hits

  • Select :settingsicon: Settings
    • Apps & notifications
    • Tap: ‘See all xxx apps’
    • Tap :dots: top right
      • Tap Show system

Continue below

  1. Scroll to Bluetooth (Bluetooth MIDI Service is shown below it) … BOTH should be cleared
  2. Select Bluetooth
  3. Select Storage
  4. Clear Cache (I would clear both Cache & Storage)
    back up and then repeat steps 2 to 4 for Bluetooth MIDI Service
1 Like

under bluetooth midi and share it says clear data and clear cache. you dont want me to clear date right, cache is empty

its connecting now thanks for your help.it worked on the 17th attempt.

Normally you would want to clear both cache and data, as this removes any corrupted data and provides the opportunity for a clean start.

if i tap delete data, it would be like rebooting and starting with a clean slate…right now everythings working so i’m not going to do that. when i tap settings it says bluetooth off but when i tap bluetooth it says its on. so maybe clearing data might realign things. and the next time my app would load the first attempt… maybe?

I have no idea, but based on all I know, its the reason that the final ‘fix’ for these odd one-off problems is to do a Factory Reset … but if its working now, lets just enjoy that and hope it last for you

Message an
Expert customer