Browser Error when accessing support pages

#1

Same error on chrome, safari, and Firefox on iOS 11. Works on android. I cannot access any page that starts with “Republic Help”. All fail with an error. I get a "snap"error on chrome.

I’ve reported this to support and it has been acknowledged. However, it’s been awhile since I reported it, and I’m stuck unable to access key support info.

Has anyone else seen this error?

#2

Hi @ceedee,

I’m able to recreate using Safari on iOS 11.1 beta 2 (iPad) and iOS 11.0.3 (iPhone). I no longer have an iOS device on iOS 10, so am unable to test that scenario. Did support happen to mention if the issue was related to iOS 11 specifically?

#3

Hi @ceedee,

We are aware of an issue accessing the help page from iOS devices and are still working to resolve the issue.

Are you able to bypass the initial help center landing page and view our Support Notes page?

#4

I cannot get to the Support notes page either. Same issue as what @ceedee reported.

#5

Thank you for checking.

@ceedee please let the Community know (or DM me personally if you prefer) if there is something specific you need help with while this is being resolved.

#6

I am not. Is there a workaround while you pursue a fix? Note that I cannot get to any of your support information. Zero!

#7

I do not know of a workaround (bypassing the landing page was an attempt to determine one.)

#8

Do any of the browsers that are failing to load the Help Center offer developer tools that might pinpoint the error causing the page to fail to load?

#9

No idea. I am not a developer. Perhaps others can chime in. I’m happy to provide a log if someone can tell me how to generate one.

#10

Safari does not. I doubt other iOS browsers do. Browsers on iOS work differently from Android and desktop (Windows, macOS or Linux). They’re all essentially wrappers for Apple’s WebKit browsing engine. Apparently, there’s some kind of conflict between WebKit and what I presume is the Zendesk hosted help pages.

I do see options for “Experimental WebKit Features”. I’ll try to find some time to experiment with whether some combination of those might help.

If it’s helpful to Republic’s developers, these are the features I’m referring to:

1 Like
#11

I just turned off JavaScript on safari, and it seems to work. Not sure that I want to leave JS turned off, but this might help,the debug process.

1 Like
#12

I’ve already tried turning off JavaScript. The help pages load, however, search (which presumably requires Javascript) seems not to function.

#13

Dang!

#14

Well, it would seem we’ve narrowed it down to a JavaScript issue, so that’s progress of sorts. I do see a Web Inspector feature that might be the developer’s tools @southpaw referenced. Accessing that requires tethering the iOS device to a computer, then using the Develop menu on the desktop version of Safari. I don’t have time to see if doing so might be useful at the moment but perhaps in a day or two.

1 Like
#15

Tried the web inspector, but i don’t know what i’m looking for! anything here of interest?

1 Like
#16

That’s good @ceedee, I’ll add a your image to the master ticket on the issue. That error by embed.js may be what we need to dig into further.

#18

I also think I saw some errors related to directly.com, but now I can’t find the text. Sorry.

#19

Thanks for your help with this!

#20

I have no idea if this helps but this is the JavaScript Console for Safari on macOS:

In theory, WebKit should be the same across macOS and iOS but that may or may not be reality. Republic’s help pages seem to work fine with Safari on macOS. If it’s possible maybe comparing the JavaScript Console on macOS with that on iOS would be enlightening. @ceedee, for what it’s worth, I’m not particularly certain what I’m looking for either but thanks for piquing my curiosity. :slightly_smiling_face:

1 Like
#21

Hah! More fun to run by the seat of our pants! I had to use a mothballed version of Safari on my circa 2006 Win 7 laptop, because safari is no longer supported on Windows.

Keeps me out of trouble!

1 Like
Message an
Expert customer