Call Block Tools

Moto Something

Republic Service


Issue Description

I am looking for a way to simply send all calls to voicemail UNLESS they are in my contacts.

Either set all contacts into a group with a ring tone or a priority to ring through to me in an “Away” or “Do-Not-Disturb” Mode.

But the simplest is for the phone to only ring if a caller is in my contacts, all others go to voicemail.

There must be a way of doing this … but I haven’t found it yet.

Ideas? Suggestions (third party apps need not apply).

You’ve actually described the way to do it. Put the phone in Do Not Disturb with Priority Calls ring through and add all contacts to the priority list. Depending on which phones you are using some can also offer to let calls from “all contacts” through in DND.

Other than that, I haven’t seen a reliable way to do this.

2 Likes

Marking 50 or 100 contacts as priority just seems like a lot of work to get a simple function set. It’s almost like the phone vendors are in on the spam effort and get a kickback for NOT doing anything to help users avoid the spam.

Did you look to see whether your phone has this option?

1 Like

Buried several layers down, it appears one of the later updates has added this “Allow contacts” option (I had looked several months ago and nothing like it was available).

Thanks for suggesting it - I probably would not have done a deep dive thru the menus again without it.

1 Like

Except setting priority, then selecting contacts only, my friggin phone still rings through calls that are NOT in my contacts. Just had another one. Last time it happened I thought priority had expired, it hadn’t. And now this call, still got through and rand the phone. Since the caller id is the number, it isn’t in either of my JUNK contact lists. And Priority is ON. Screenshot with settings.
What else can I do to make this work?

Hi @timm.l2n5o1 ,

It looks like you have the settings correctly configured. Are all calls from numeric caller IDs getting through?

Yes - so i was thinking some of the calls were buried in my two JUNK contacts… they aren’t. So I thought, mayby having hundreds of numbers in my contacts is slowing things down and overloading the priority filter: so I deleted the two JUNK contacts (~1,000 NUMBERS REMOVED).

Three calls yesterday, and another two calls made it through this morning. All local prefixes.

So the filter is not working as designed. As far as I can tell, it is doing nothing. Will try blocking everything just to test if it does work at all.

If it matters, Moto E4-Plus. Just did the latest security update, and that also made no change.

The “priority” setting isn’t meant to “block” calls. It’s meant to silence calls and, depending on how you have it configured, their notifications.

When you say these calls are still coming through, does the phone ring audibly when “priority” is enabled?

Yes, the phone rings, connects to any Bluetooth headset within range, and shows the on-screen notification a call is pending; exactly the same behavior as the DND setting is OFF.

The only odd thing I’ve noticed is unwanted calls will go to voice mail after just a couple of rings, rather than the full 6 rings I have set.

Another oddity: I tried DND once before, a long while back, and seem to remember setting DND had no effect whatsoever then, and back then it was my attempt to Total-Deny-Everything. If failed miserably – so I started using airplane mode - it actually worked to block incoming calls, texts, etc.

I’m thinking the phone has a major bug.

If any of the phones on Republic had a bug that prevented DND from working it would be known as there would be dozens or hundreds of complaints. There aren’t so we need to figure out what’s going on with your phone particularly. In your quest to block calls have you installed any apps for this purpose? Changed the default dialer? Anything like that?

I am a very strict no weird app user. I have an app for viewing topo maps, Kindle reader, and a WiFi signal strength viewer for watching my home network. All are except maybe the Kindle app benign unless running.

I have reset and disabled many of the Google android apps that drain the battery … specifically any that use location. I’ll try going through that list to see if any might be tied in to call services, but Google hides why they want certain apps running 24/7 … so who knows.

I believe an update goes back and re-enables all the standard Android apps, and I haven’t done a clean up since the last update about a week back. So everything should be back to factory.

But I’ll check. Though if I did kill something that is essential for blocking calls, you’d think I’d be experiencing other call related issues, like no service at all.

Here are the things currently disabled: nothing that would prevent call processing. Unless Google Play services is hooking in somehow and watching each and every call (which according to their pricvacy rules they should not be doing, right?) …

Where have you set six rings?

I set that when the phone was new years ago. Yesterday I tried to find the setting again and no luck.

Just thought of this: it may have been something in one of the included Moto apps I’ve since ditched? I’ll go back and look in those.

Two more calls today … 1.5 rings … then the call goes silent.

New info: pretty sure the bug is related to BLUETOOTH. The cell is not ringing; but any bluetooth device connected rings with Priority DND set.

So now to figure out how to block rings to head sets.

This defect was first reported in 2017 … ■■■■. Problem is also present on most Android phones and even Apple iPhones. We MUST protect you from yourself and let anyone contact you if they need to!!!

Message an
Expert customer