Call "echo" with bluetooth and cordless phones

#1

I’ve inquired about this problem before. Problem still persists. My setup: Am pairing via bluetooth, moto x gen 1 and moto x pure to cordless phones. In dealing with initial problem back in April, AT&T ended up replacing cordless phones. I also worked with Republic to remove some phone apps that might contribute to problem. Back then, using moto x gen 1 only, the problem disappeared. Sadly the problem is back. Seems present most of time. Yesterday I paired my Moto x Pure and echo was present when calling both cell and landline phones. This AM I called friend on his cell phone; echo present but he indicates he always has echo problem. I placed another call to a landline and no echo in call. Note: I don’t hear any echo on my end. All echos are on “others” phones.
Do you have any recommendations? Since problem was temporarily solved on gen 1 moto x, I’m hoping that problem might be recent /or updated apps.

thx for any help and suggestions.

Steve M.

0 Likes

#2

Echo is always present, both on cell and WiFi and is not limited to your cordless phone or the Republic device/service. The highlighted 1st paragraph of an article by VoIP Info explains at a high level
Anything on your phone that adds delay in the path can add to the problem … some things to check

  • Any Echo when you are not using the AT&T device (I assume you are Bluetooth attached to them)?
1 Like

#3

echo on nexus 6p has peersisted even tho “factory has reset reman” phone as per republic insisting I do so. People that I call, they call me can hardly carry on a conversation due to the persistent poor call quality either on cell or wi fi

0 Likes

closed #4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

0 Likes

Message an
Expert customer