Call Ended: Microphone in Use -- Note 9 (problem on WiFi only)

master_ticket

#1

I have a Samsung Galaxy Note 9 and I am on the $15 talk and text plan (I only purchase cell data when traveling and the last time I did that was in December).


I tried to make an outgoing call today and received the following error message:image

If the image doesn’t upload, it says, “Call Ended: Another application is currently using your microphone and won’t share, so we had to end the call. If you have a call recording app, please uninstall it. [DISMISS CALL BACK]”

I disabled all the apps that had permission to use the microphone. I restarted the phone afterwards. I deleted any apps that I thought might be responsible even though they hadn’t updated or been used in a while. I rebooted again. I performed some device maintenance (clearing cache, freeing up space, etc.). Restarted again. Nothing worked.

The phone will still receive calls. It also will send and receive texts.

Interestingly, while looking for answers on this forum, another user with a Pixel had the same error message while trying to use Google’s call screening feature. While I clearly don’t have the same issue (different phone and it’s happening when I’m trying to call out, not answer), they mentioned that the phone worked when they turned off WiFi. It turns out my phone is the same. If try to call using cell not WiFi, it works.

Does anyone have a suggestion for fixing this issue?

It’s not an immediate problem since now I know that I can make calls, but I prefer to use WiFi whenever possible since I work in a basement and that connection is much stronger than my cell coverage.

Thanks!


Another application using microphone and cal hangup
#3

Hi @jorandyl

I think I would try booting into safe mode and seeing if the problem persists. If safe mode fixes the problem we know it is still an app issue. If not, well then maybe a refresh of the RW credentials would help.
How to Refresh the Republic Wireless Activation

This is as least a place to start till others chime in :wink:


#4

Safe Mode won’t work in this case. In Safe Mode on the Note 9, the Republic App does not load and it isn’t possible to test wifi calling.


#5

My son as a factory unlocked Note 9 that’s not currently active on Republic. Tonight I’ll transfer my Republic service over to that phone and see if I can replicate the problem. It won’t be until tonight before I can attempt this though.


#6

I have exactly the same problem using Galaxy Note 9 unlock phone with RW clear choice plan. The problem just starting yesterday (2/7/19) when placing wifi outgoing call. I tested the wifi call to many family members and it only happened to some numbers, not all of the numbers. When I disable the wifi, all the out going call work perfectly without that popup message showing microphone been occupied by other app. I wonder is this RW issue? Any info to resolve will help. Thanks!


#7

Hi @jessica.tien and @jorandyl
I wonder, is your Note 9’s using a Samsung dialer ?
I have heard they have their own messaging app that is troublesome with RW. I wonder if the same is true for the dialer.
Are you able to try the Google dialer and see if that makes a difference?
Google Dialer


#8

The Google Dialer only installs on the phones that it is made for. The Note 9 isn’t one of them.


#9

Oh well just a thought .


#10

I have no idea if this information would be helpful to those who are trying to help troubleshoot this issue, but @jessica.tein do you happen to know if the numbers
that you called and that worked were landlines or cell numbers (and if cell, what carriers)?

In my case, none of the numbers I tried would work without the error message. One was to another MVNO (Ting) number and the other two were to landlines.

I tried again today, and the person whose cell I tried to call did report that his phone rang once, so the call is going out but my phone is just not letting
the call last beyond a second before cutting it off.

Also, I tried doing a video call with Google Duo over WiFi and that went through fine. I haven’t tested other apps like WhatsApp yet, but I’m guessing that that
will also be OK. This issue seems isolated to using the Samsung dialer with a RW account.


#11

Would installing a 3rd part app like Revo App Permission Mgr possibly help identify who/what is holding the Microphone?
I just installed in on my Moto X Pure, and selection the Permissions Viewer (bottom left on home screen) provided a Selection scroll bar at the top. I then selected Microphone and it shows all apps (internal or 3rd party that has permissions for the Microphone. Then by drill down you should be able to enable/disable the permission.

  • Post back anything you learn if you try this as by use is limited to the last few minutes installing etc

#12

I apologize, I didn’t get to test this last night. I’ll see if I can duplicate tonight and if I can I’ll make sure to open a ticket with Republic support through the app to get them the additional diagnostic information.


#13

@jorandyl and @jessica.tien,

We’re currently investigating this matter.
Would you please open a ticket, provide as many details as you can, and ask that it be investigated with master ticket 1589976.

@louisdi, if you’re able to replicate the issue, would you please also open a ticket.

Pinging @Ambassadors for situational awareness.


#14

I was indeed able to replicate. I’m going to try a few things and I’ll report back. I’ve noticed some updates to things like the Samsung dialer that are out there, that I’m going to side load and see if there’s any impact. I’ll report back later tonight.


#15

As I was typing up a ticket and trying to add more detail, I discovered that there appear to be three Samsung dialers installed on the machine (two labeled as version 1.0.0 and one as version 3.0.30.26. I believe that the version 3 one is the most current. However, one of the “version 1.0.0” apps was the only one with a gear icon that would allow me to access the call settings.

Under call settings, Wi-Fi Calling is Disabled. That seemed like a pretty promising lead, so I toggled that off and tested the phone again. This time, I was able to complete an outgoing call using WiFi.

While this seems to have solved the problem, I’m a little concerned about how that setting might have been disabled in the first place. I also seem to have a vague recollection that, during the activation of either this phone or maybe one of my old ones, the RW app actually wanted it set that way. Am I mistaken, or has that perhaps changed recently?

In the meantime, @jessica.tien, maybe you could also try checking the call settings to see if your phone is set the same way.

Under Settings > Apps, click the three dots to make sure that it shows all the system apps. Find Phone and then click on the first one (if you have multiple ones like I did). Click on the gear icon above the “Force Stop” button to open Call Settings. Scroll down to Wi-Fi calling and see if it says disabled in grey. If it is, try clicking on that and see if the “Disabled” switch is toggled on (blue) or off (grey). Switch it to the off position and see if you can now make an outgoing call.


#16

That’s interesting. This settings should not impact anything on a phone in use with Republic, because the wifi calling is handled by the Republic App. In fact, on previous phones, attempting to enable wifi calling in the dialer like that would fail and throw and error. I should be able to try this in about an hour. I’ll report back too.


#17

OK Here’s what I’ve found:

@jorandyl is completely right.

The quick solution is to simply open the dialer, hit the three dots on the top right, select Settings, then Wifi Calling and then toggle that switch off. Voila, problem solved.

Just as a note, wifi calling continues to work.


#18

Pinging @Ambassadors and @Experts for situational awareness


#19

Okay, I tried @jorandyl 's solution and it work! I have been using my unlock Note 9 with RW for more than 2 months without any problem. I believe something must be changed recently. Thanks to all the experts, this community is fantastic !!


#20

Big Thank You from me as well ! I was going to open a ticket today but checked this thread again and tried @jorandyl solution and sure enough calls are working again.

Puzzled as to what happened, like jessica.tien I have been using my Unlocked Samsung Galaxy Note 9 for several months with no issues. And this issue only popped up a few days ago. Could this have been an issue with the recent maintenance I wonder? Only affected Note 9’s? Guess I should just be happy it’s working and move on. hee hee. :grin:

Just curious, does the “Wi-Fi Calling” change on anyone’s menu when toggling? Mine always says “Disabled”.

Should I go ahead and open a ticket and notate it as working now so Republic can get an idea on how many were affected by this?

Thanks Again Everyone!!!
Daron


#21

Hi @jorandyl,

Great work troubleshooting! Thanks for all the details along the way, and for sharing your solution with the Community. So many people just disappear after solving their issue, and they never come back to tell us what the solution was.

We’re now offering your solution to our members who open tickets with the same trouble.

@jorandyl, may we send you a Republic Wireless T-shirt? If so, please DM me (don’t reply to this, even by E-mail, since this is a public conversation) with your preferred size (S, M, L, XL, 2X) and best address.

I’ve also placed a credit on your Republic Wireless account, so that your next month of service is on the house, to thank you for bringing this matter to our attention and sharing the solution when you found it. While you’ll no doubt continue to receive “thank-you” replies, please also know that there are many “lurkers” in Community who visit, find what they need, and move on. Your post is helping more people than those who will take the time to offer their thanks.