Call Guard roaming message

After doing the system update this morning, I now get a Call Guard pop-up when I go to make a call. Sometimes it warns me about international roaming charges that may apply. Sometimes it is a warning about domestic roaming charges. Either way, I can’t get past it to make calls.

I tried this solution several times that was recommended in an earlier thread, but it did not stop the pop-ups. So if anyone has any other suggestions, that would be great.

@louisdi Jan 2, 2016 10:12 AM

Yup, there was an update on the Sprint side that cause this issue… Following these steps, WHILE ON WIFI, will resolve the issue:

  1. Restart the phone.

  2. Reset Republic credentials - Open the dialer, then dial ##8647## while on WiFi.

  3. Update the PRL (Preferred Roaming List) - Go to Settings then System Update then Update PRL

  4. Wipe Sprint settings - open the dialer again and dial ##72786#. (You will get a scary message about things being reset, don’t worry, none of your personal information is impacted, you should say “yes”.)

  5. Update the profile - go to Settings then System Update then Update Profile. (Again while on wifi)

  6. Restart again (If it doesn’t automatically)

1 person found this helpful

Like • 0

Actions

What solved this for me was acknowledging the notice with an OK to roam response. I don’t remember precisely what the dialog box says. Roaming data is used for call setup but you will not be charged for that roaming or international calling.

Thanks. That seems to have done the trick.

Worked! Thanks!

I could not dial ##8647## while on wifi. I get a popup that says Republic Wireless - Dialed number not allowed.

I went back to try to make sure that I was on wifi and not cellular (not exactly sure how to do that) and this time is said number unreachable

Hi @coach_kujo,

Our new forum software borks the number sequence. It should read *#*#8647#*#* rather than ##8647##. That said, simply acknowledging the message on your phone by tapping OK should be enough to make it go away. It’s a spurious message, there will be no additional charges beyond monthly plan fees for international roaming or anything else.

Thanks. I did reset the PRL. That seemed to do the trick. Perhaps that was enough.
I am not even getting the message at the moment.
When I acknowledged the message by hitting “ok” before - nothing happened - the message just immediately popped up again.

2 Likes
Message an
Expert customer