Call only rings 1.5 times, then it goes to VM

Update.

I opened a ticket, giving them a list of the calls and times when this issue happend to me. Hoping they could look into the servers and see. I was told that they can only look at the last 72hr history though. I was told they found nothing out of the ordinary, and they sent me a new SIM card to see if that fixed the issue.

It at first seems to have fixed it, but the contact had only called me 1 or 2 times since I installed the new SIM Card. We both got got sick, then were very busy afterward with work related tasks, and did not talk to each other at all. But just now, he called me and the issue happened. I go to update my ticket, last I left it I told them I need a week or 2 before I would know and would get back to them, but ticket is now closed out and my reply will not go through.

O well. I guess it is just a Pixel thing…or something with him being on Cspire?

Just to update…this still happens.
It happens sometimes, but then not at all for weeks.

I just happened a couple times over the last few days.

I have been stuck home for a while, with phone in Airplane mode, wifi on.
So that force the call to be wifi only.
It still did it when certain person called me.

This topic came up in another thread where I mentioned some other things, link here:

So, it is happening again, alot with the 2 contacts that call me frequently.
The main contact, his work schedule had changed, so I am probably not gonna hear from him as much now moving forward.

Seems that being on wifi only(no cell), no mater the wifi network, 2.4g or 5g, has no effect on this issue.

The only thing i don’t think i have tried, is to stay on cell only, no wifi…which i could try for a bit i suppose, just have to remember to not do anything data intensive.

@southpaw could DM me info on that ADB hack thing your team has come up with that u mentioned at some point. I would like to see what that is about and the pros/cons of trying that. ( i have seen ADB hacks cause serious issues before). I may consider giving it a try.
thanks

i could try the MacroDroid Doze mode thing again, but the only one i see in there states its for Android 9.0 and lower…i have 10.

The reason I state “Doze Detect 9.0 and below - ver 0.9.6” is that I have only a Moto X4 to test on, if you would download it, determine the condition when it fails and provide screenshots of the logs, I would be glad to work with you to see if it something that I am able to fix.

1 Like

There’s no hack that “our team” has come up with. Let’s not take that route since you’re concerned about serious issues.

If you’ll continue to add to the symptom list, I’ll be compiling a list to present to the developers after I’ve had some time to replicate the issues myself.

That gave me the impression that you guy had come up with something?
I guess i interpreted that wrong.

Logs? i was not aware or know of logs saved by macrodroid.
Where/how does one view the logs of the macro?
Last i tried it, it just did nothing noticeable.
I see the code has mention of an RW notification…does this mean that the persistent RW app notification needs to be enabled?

Again, i do not think this has to do with doze mode, as the issue has happend when the phone is active, in use, even. But i can still give it a try anyway.

There exists on the internet a method using ADB to disable two doze mode functions. I’ve tried it personally and found that my phone does not move from a solid arc to an empty arc after an hour of not being used.

This has nothing to do with anything any Republic Wireless team is working on toward engineering a supported solution. I’m curious to know if the calls going to voicemail issue is also improved in this state. (I don’t get enough calls to notice and don’t have time at the moment to dedicate to testing it.) I thought it might be something you’d be interested to try, but I do not want to encourage such a trial given your predetermination that it is risky, because then, should anything at all happen to your phone, you may blame me.

Logs are available as ‘User Log’, in the Doze App :menu: but if the problem you are having occurs even when active (in a call, or screen displayed), then AFIK it is not a Doze problem

Ah. I see. Thanks for that clarification.

What is Doze app?

When a user has installed MacroDroid and is using the Doze Detect 9.0 and below - ver 0.9.6 that I have published (found in the Template section of the MD app by searching) you can then access the :menu: and select User Log … sorry if my short response caused additional confusion

i do not have a 3 line button like that.
There is one with dots infront of it, but that is to select macro category.
There is 3 dot menu, but I do not see a option to see log.

From your 1st screenshot, hit the top left back arrow 2 times, this will take you to where you should see the hamburger menu

O. It is on the main app screen, not in the macro it self screen.
Thanks.

Is there nothing supposed to be there, even if u run Test actions with the Macro?

edit: when i enable the RW persistent notification, then i do see entries in log…
so this is dependent on the RW notification.
But it just keeps just locking my screen.
Might be causing a System UI crash and recover.

The Macrodorid System log is saying Error: Notification content info was null.

Ok. so the macro and RW notification is enabled.
My mother just rang me. Phone has been sitting for a bit, i look over to it, it shows the incoming call screen, ring 1.5 times, then says called ended. and goes back to lock screen.

The RW notification is saying on cell, no acces to messages or voice mail…
However the phone is on wifi and gets VM and messages fines.
I unlock the phone and the RW notice goes back to connected.

This is getting annoying. I even have MacroDrod set to email me for missed calls, but since this issue does not trigger a missed call, it does not send an email. And there does not seem to be anyway to make a Google Home mini announce or ring at same time as phone…

Any suggestions?

I think my next test will to be just not use wifi and see if it happens on cell only.

I have set my router to block UDP port 5090.
That results in all calls being on cell, but i can still remain on my home wifi.
I am gonna see if this stops the issue at all.

I’m curious as to what router model and firmware you are using. I always believed the doze mode wasn’t a problem as long as you had adequate cellular signal. Might be more of a router NAT issue.

I have had multiple routers over the last few years.
And the issue happens out side of my home, at work and at my grandparents (noted some where in all the posts on here…lolz.)
So, it is not my network, or phone, (as it did it with my OG Pixel XL) after I moved over to RW.
Never happened in the year i was on Sprint, or before on TM, or VZW.

But to answer your question, I previously have had a Asus AC68U router, then a AC86U router.

But a bit over a year ago or so, i went to Ubiquiti hardware. I currently have a EdgeRouter ER-4 and a Unifi NanoHD wifi AP, and a Unifi 8 port POE switch. And all Ethernet cables are CAT6A Shielded.

If you’re convinced it’s not your W-Fi network, I would pose one further wild inquiry. You don’t have Wi-Fi calling enabled in the Phone app, do you? I wouldn’t think it was possible to enable, but I’ve seen stranger things.

  1. Open the Phone app phone.
  2. Tap More More And then|autox18 Settings .
  3. Tap Calls .
  4. Tap Wi-Fi calling . If you don’t see this option, it’s because your carrier doesn’t support this feature.
1 Like

There is no wifi calling option there.

I do now get a enable Wi-Fi to make a call message propped what I tried to dial out when an airplane mode now since Wi-Fi calling is blocked in my router and when I click the option to show Wi-Fi call settings it’s just a blank screen.

1 Like
Message an
Expert customer