Caller id

How do I turn my caller id on so that when I initiate a call they see my name and number? I have the Moto 5G Plus, but I don’t see that exact phone listed below.

I found a post elsewhere that said to go to the phone icon > menu > Settings > More Settings, but I don’t have More settings. I have “Calls” but nothing in there.

Thanks Much in advance.

There is no “turning the caller id on”. It’s just on. If the matter is that the name is incorrect or not coming through you can ask Republic to update that. Here are directions: https://community.republicwireless.com/docs/DOC-1959-make-and-receive-a-phone-call#jive_content_id_Caller_ID

Message an
Expert customer