Calls and data over WiFi - No access to messages or voicemails

What phone do you have? Google Pixel 3

What plan are you on? Yearly 1 GB

Does your plan include data, or just talk & text? Data, talk and text


Issue Description

For the past 3 days when I come into work my phone goes states “calls and data over WiFI - no access to messages or voicemail”. I did the troubleshooting steps yesterday that were stated in a previous thread (refresh activation, clear the cache, reset network settings) and it worked yesterday. Now today when I get to work I’m having the same problem. Never had this happen at work before. What can be done to fix it?

Hi @suzannet.1zcgiu,

If this only happens when connected to your work’s WiFi network, it suggests that WiFi network is blocking the MQTT protocol Republic uses for both voicemail delivery and text messaging over WiFi. You might ask the IT folks at work about that possibility.

If you temporarily disable WiFi on the phone, are you able to access voicemail and text messaging?

If I disable WiFi is states "Calls over cell: No access to messages or voicemail. I refreshed the activation this morning and about 30 minutes later it started to work. It worked for 3 hours and now I’m having the problem again.

We’ll need a bit more information. May we know the zip code where this is happening? May we also know the brand, model and generation of your phone, please?

Zip code is 53151 - Google Pixel 3 running Android 10

Hi @suzannet.1zcgiu,

Thank you for the additional context. Would you be kind enough to let us know one more thing? Specifically, may we know if your Pixel 3 is provisioned with GSM or CDMA coverage? Here’s how to tell:

It is GSM. My son is having the same issue when he is at our house which is just a few miles from my work. He bar that shows coverage will have an “X” at times and sometimes it then changes and it is fine.

Good Morning @suzannet.1zcgiu,

Thank you for being willing to supply additional context by answering my questions. Now, it’s time for me to offer some context to you.

As you may know, Republic offers multiple coverage options for its newer compatible phones. Republic provisions cellular coverage with one of two network partners. One partner operates a GSM network and is T-Mobile. Republic’s other partner operates a CDMA network and is Sprint. T-Mobile and Sprint have merged, however, the networks remain separate. Cellular coverage is provisioned with one network or the other not both simultaneously.

Additionally, due to its unique nature (sufficiently unique to be patented), Republic’s blended WiFi/cell service requires access to data (WiFi or cell) in order for text messaging to work and also to receive voicemail notifications. Cell data used for these purposes is whitelisted meaning we do not pay for it above and beyond plan cost nor does it count against any cell data purchased as part of one’s plan for Internet access. That said, when away from WiFi (or if one’s work WiFi network is blocking the previously referenced MQTT protocol), cell data must be available.

The “X” you note indicates the cellular tower a phone is connected to is not supplying data likely because it is a roaming tower (a tower owned by a partner of one of Republic’s partners). A Network Settings reset or even merely restarting one’s phone might temporarily “fix” that by changing the tower a phone is connected to.

All of the above said, I believe it would be possible to improve your experience. Doing so would require a change of provisioned coverage on your Pixel 3, which is accomplished by acquiring a different SIM from Republic. How to make that request is linked here:

Your son might benefit from a change of provisioned coverage as well. For more insight on that, we would need to know the brand, model and generation of his phone?

I got the new sim card and I now have service but it is showing up as a different number when I text…how does that get fixed?

Hi @suzannet.1zcgiu,

Is the correct number showing when you open the Republic app on your phone? Is it all text messages showing a wrong number? Or, might it be just some? I’d suggest this as a starting point:

1 Like

That seemed to work but some people have told me that when they send a text it just says “sending”. How can this be fixed?

That’s not something you can fix on your end. They may need to delete any threads with you and start a new one or restart the phone on their end.

That doesn’t seem right - how am I suppose to know if they are having issues? How am I suppose to know if I didn’t get a text I was suppose to and how would they know I didn’t get it??? There has to be a better solution.

Unfortunately because of lack of co-operation from the major carriers Google decided to roll out this Chat (RCS) feature without consulting any of the carriers. They just turned it on for people. They did it not only for the major carriers but for MVNOs like Republic too. Even more unfortunately this means that testing wasn’t done for compatibility and wouldn’t you know it, there are issues.

I know the answer provided wasn’t exactly satisfactory, but Republic doesn’t control RCS, Google does. And Google doesn’t control the standard as to how RCS works, it is controlled by a standards body, and Republic hasn’t been asked by either as to how it might or might not work with their hybrid calling.

So, bottom line, there are problems, but all we can do as customers is work around them.

1 Like
Message an
Expert customer