Calls dropping: Moto X4 and Verizon Jet Pack

What phone do you have? Moto X4

What plan are you on? My Choice Talk & Text + 3G cell data

Does your plan include data, or just talk & text?


Issue Description

I live in rural area & only have Wifi usage @my house. I was speaking w/our Secty of State office & was disconnected 6 times in a 15-min call!!!

I was sitting no more than 6’ away from the jet pack that has our signal & my phone indicated that it had a full signal at all times???

This is Beyond frustrating!!!

The provider is Verizon.

Thanks in advance for your assistance.

I don’t know that there’s much Republic Wireless can do about this. If you don’t have a cellular signal on your phone you’re at the mercy of the quality of connection of your Verizon mobile Wi-Fi (MiFi). Verizon mobile internet can be highly variable in terms of quality (latency, jitter, and bandwidth).

MiFi networks are generally not reliable for use with VoIP calling as they either do not provide sufficient bandwidth and/or traffic is often throttled by the MiFi network operator. There is no solution or setting that can improve this performance on MiFi networks.

A thought and a questiom:

  • If you have not already done so, I would place the X4 in Airplane mode then turn WiFi back on (note the RW Arc will not change, this is an Android thing, not Republic)
    • This would eliminate the possibility of the phone trying to shift over to a normally non-existent Cell, but with all the changes T-Mobile/Sprint are making, one can’t be sure.
  • Which Jetpack do you have, and have you done the basic power off/on reset of it?
    • Also are you connecting to a 2.4 or 5 Ghz signal from the Jetpack? (the 5Ghz is normally very susceptible to interference and only good over short distances (no walls)

Thanks jben!!!

First- are you saying to “leave” it in Airplane mode?..will I be able to use the phone w/it on? Is that something that I’ll want to do on a permanent basis when I’m in the house?

We just re-set the jet pack…Model #:8800L Software version 2A

I was able just now to have a phone conversation for more than 30 seconds…

Thanks again for clarifying my issues, Lisa

  • Yes, I would set it in Airplane Mode and turn on the WiFi when home on a permanent basis.
  • Spent some time going over their doc, but it is still unclear to me if a user can use separate Network Names/SSID to each of the bands (2.4 Ghz and 5 Ghz), so my guess is you have no control over this. This means that the Jetpack makes the decision for you and you can’t log in separately to one band or the other.
    • If you don’t know, you might want to contact Verizon and ask them.
      My recommendation would be to have the devices that require high speed on a 5Ghz SSID and the others on the 2.4Ghz SSID
    • I they say this is not possible, then you can check your phone and see which it is to connected to, Settings / Network & Internet / Your Network Name/SSID then tap and it will show signal strength and Frequency.

A general WiFi Tips & Tricks is available, not everything will apply but it may help some …it is called Router Tweaks - Keep WiFi 1st - a Community Guide

Message an
Expert customer