Calls end during the call


#1

What phone do you have? Moto E4 Plus

What plan are you on? My choice + 1 gb

Does your plan include data, or just talk & text? included data


Issue Description

This has been an ongoing issue but has gotten really bad in 2019. This happens on wifi only. I’ll be on a call and it drops on my end and the call timer will run for about another 30-45 seconds before it ends. I hear a beep when the call drops so know its over.

The other person will hear silence and often continue talking not knowing they were cut off. They’ll get the dial tone after about 30-45 seconds or try calling back when they discover we’ve been disconnected. This mostly happens on a long calls at around 1 hour and 2 to 10 minute time frame. It is now happening on short calls which is getting annoying thus this call for help. It happens on multiple calls to different phones and numbers all none republic customers. It does not happen on cell so I’ve starting using that for most calls that are important.

Suggestions welcome as using cell isn’t what republic is about.


#2

You may be suffering from interference from a nearby neighbor, they may have just upgraded their router and are now on top of yours. I would suggest the following course of action.


#3

Thanks for the detailed link. I’m traveling till Saturday so when get home hope dive into this over the weekend - time to do all this is the issue. I live in a rural area and have no neighbors wifi signals around me. However, am on an radio frequency (RF) connection for interenet and have had issues in the summer when firefighting equipment is in the air as county airport is retardant/refueling/smoke jumper base. Or so my isp says. Thanks


#4

The service you have sounds like a WISP (Wireless Internet Service Provider), so the ‘channel’ problem I initially thought, would not apply.

  • The 30-45 sec timing mentioned could possibly be attributed to a poor/non existent Cell coverage
    • You might try placing the phone in AirPlane Mode and then turn the WiFi back on as a trial/test

automatically bumped #5

automatically bumped #6

#7

Hi @blackdog,
Did you have a chance to the AirPlane Mode … WiFi on that I suggested?


#8

Thank you for following up and apologies on slow response. I just do not have the time now and go to cell when needed. When I can run through the check list will let you know. – jim


#9

Hi all,

I second blackdog’s comments but do not believe the fix described applies to me…

I do not usually make many phone calls but recently I had to send and receive dozens of calls a day (during and following my elderly Mother’s final illness). Any calls that lasted longer than about 8-10 minutes were dropped exactly as blackdog described. Since these calls were with doctors, grieving relatives, funeral homes, etc. the dropped calls were a HUGE problem.

These dropped calls are especially bad, because unlike blackdog the calls do not hang up until I realize the problem and manually end the call. So I can keep talking for a minute or two before realizing there is no one listening!!!

Unfortunately my issue cannot just be my neighbors’ wifi. These dropped calls occurred at my home, at my Mother’s home, in the hospital, in a restaurant, at work, etc. And I live and work in the center of tech-heavy Seattle WA. The cell service here is perfect. I conclude it is either the wifi or the Republic software causing the issues.

Until now I have been happy with Republic and have been a customer for years. But when I really needed to make vital phone calls I was let down by Republic. HARD. Once I have time I will research Mint and other lower cost options.

FYI I have the exact same phone and plan as blackdog: Moto E4+ and my choice+1 gb

M-Jo

P.S. I looked at the suggestions to powercycle wifi connections, etc. But in a family emergency I did NOT have time to troubleshoot my connections. I needed to call family, etc. without disrupted calls!


#10

How do you “go to cell when needed”? Can you choose cell only: 1) before making a phone call and 2) during a phone call? How?


#11

I would suggest you Open a Ticket with Republics Tech team and work with them to see if they can provide some better direction for you.


#12

Hi M-Jo,

Go to your home screen, pull down from the top and turn wifi off. Or go to settings, select wifi and turn off. Then you’re on cell only. Do this before the call. I’ve done it mid-call if I forgot to switch and sometimes that terminates the call. The phone will bother you to turn wifi back on but ignore it. Definitely wan the dependability when on important calls.