Calls going straight to voicemail in last few weeks

According to our Help Center documentation, the RW app will continue to work on the G7 in Safe Mode.

Ok, I’m hoping to get the safe mode call in about 15 min

The call nor text came though via safe mode. :frowning:

These hotspots are generally, well, being generous, trash. They are extremely bandwidth limited, and lower priority than the traffic to the customer that’s paying for that connection. I would never ever use an Xfinity Hotspot as a test for anything that as any sort of reliance on the quality of that connection.

Thanks for the additional info @louisdi . :slight_smile:
I won’t argue your point. Tho have been using Xfinity in times of need without issue. It has worked (like my own wifi) for wifi calling in my home for years now.

The phone seems to be dozing after an hour of sitting. I have not had a problem with doze before. I have seen posts about using Macrodroid to counter doze. I guess I might have to try that. Tho again, it’s frustrating that this is something at was not an issue a few weeks ago.

Thanks again for the thoughts

So, then one thing we might ponder further, is what changed a few weeks ago? I’ve looked through our RW app releases, and the last two did not have any updates that changed how receiving a call works, nor how we send those “keep alive” messages.

Is that time period when you moved to the G7? I tested the G7 and the G7 Power and found both to be incredibly aggressive about Doze mode, even during pre-release testing.

1 Like

I’m leaning in that direction too!
I’m finding talk about Moto models on Oreo or Pie being as you say, “aggressive” with Doze.
I’m still trying things like turning off the battery optimizer.

In the next day or two I’ll do a factory reset. I don’t mind doing it and I can do that faster than getting to Starbucks for another wifi test. :wink:

Thanks for:

You’re the best!

Added: I got the G7 a few months ago (beginning of April?) So this might be how it acts with Doze vs the Pixel I had to replace.

I installed macrodroid and created the “original method” profile that @billg had posted in: Managing Doze Mode

I ran 2 test of having the phone sit for over an hour. Both times it it has woken up for the wifi call and rang me. :grinning:

I think my issue has been resolved. Thanks to all who helped!


Phone got into the same state again today. I was using it, so the phone isn’t going into doze. Either my router is, or the Republic tunnel is. This time all I did, after being informed by my parents that calls were going straight to voicemail, was turn wifi off and back on. Incoming calls started working again.

It’s not doze. It’s either router, or Republic…and I don’t think it’s the router. My wife’s Moto G5 continued to receive calls while mine didn’t. I think something’s timing out on the Republic end.

This was on the phone or on the router?

My phone wifi. I realized I needed to try that before trying a different wifi, as that was too many things to change at once. And because my wife’s phone could still see incoming calls, that almost certainly demonstrates it’s the phone and not router wifi, as we’ve both been on the same wifi for the last 4 hours or so.

If you haven’t done it yet, a complete power cycle of your home network equipment would be advised. All routers and modems are computers, and they store and use many tables to keep things running well, these can get messed up, to a point where some devices work fine, some don’t.


Sure but I think once again we’re treating a problem too late in the cycle. I can always power cycle stuff, WiFi, router, modem, take your pick (well, mine; wife is taking less kindly to this on her phone). So far some combination of those works. But I don’t KNOW to do it, because while my Republic arc is green and reports WiFi calls, incoming calls aren’t making it to the phone. Just incoming calls: internet, apps, texts, outgoing calls all still work. When I find out, I fix it, but I don’t know until I find out. That’s not really okay, and no amount of telling me to power cycle fixes the issue. The horses are already out of the barn, closing the door isn’t helping. I’m really not sure how else to get this across.

Now, if you have timed scripts that will reboot all the things everyone seems to think need rebooting at scheduled times without interfering with my usage I’d be happy to consider that a (admittedly not great) solution. Otherwise I’d like to stay focused on the actual problem: Republic seems to think my calls are coming in on WiFi, but they’re not. Even if everyone is convinced this is my phone, or my router, or something not playing nice, why is the republic arc still green and reporting WiFi calling? Is it really not supported to have no cell fail over? I’ve never seen that stated by Republic but it would explain what’s happening.

If this had happened once, power cycle, fine, move on. But this is now the 3rd time in around a month, so it’s getting BACK into some state that I have no warning of.

Hi @bobgod8,

Do you have any firewalls, VPNs or other security set up on your network?

Could we send you a CDMA SIM card for your wife just to see if perhaps there’s any difference? Sprint has made huge improvements in my area in the last few years, and I have no reason to think I’m important enough that my area is the only place they’ve been doing so.

How often can you get the phone into this state? Is it consistent, day to day? I’d really be interested to know if it also happens on other networks. Of course, since you may not be able to find another Wi-Fi network that also duplicates your particular cellular signal situation, first we’d have to know whether at home, the same things happens if you put the phone in airplane mode with Wi-Fi enabled. That way, if it does happen in that condition, you could easily test to see if the issue can be replicated on another network.


Um, I guess if you want to that’s fine. There really, really, REALLY isn’t service at the house of any kind, except for my Verizon Network Extender. So a CDMA card would allow failover onto that, which still runs via my wifi for reference. But you can’t send one for my phone as I’m almost positive my phone can’t use CDMA…

That is the question. I’ve noticed it I think 3 times on my phone and twice on hers. There doesn’t seem to be a time issue or a reason, it just sometimes happens. That’s 5 times over 2 phones in around a month. This latest time, I discovered and fixed it by simply turning the wifi off and back on, which means I can’t just go to another wifi network to test once it gets into this state. I actually have to hang out on a different wifi network (possibly in airplane mode) to wait for it to get into this state, THEN prove that it happened. That’s…not really a tenable solution, as it’s going to take an awful lot of debug time for me.

My current solution is to just scrape my existing call log from the Republic webpage ([string of numbers]) and email myself every time there’s an incoming phone call. I have a basic program mocked up on my server.
Unfortunately, the way Republic built the page, I CANNOT scrape it in a simple way, and instead have to run a headless browser and do some complicated javascript parsing to see the data; if you don’t believe me, just look at the source. As this seems like a far easier solution to me, I’d love to be able to access that data, instead of having it hidden server side. That also seems like a simpler ask than the ridiculous amount of debug time everyone wants me to do.

  • One thing that would help RW and others if this problem continues would be to note the Republic Notification present after the failure (one finger swipe down)

It’s almost impossible to catch it as it’s happening, so I’m not sure I’ll be able to show that for exactly when it happens, unless I happen to catch it in that state on purpose.

That’s as close to after as I’ve come, and I’m not sure how long after it was. As you can see the arc is solid. If the arc isn’t solid exactly when the call comes in then that’s of course the problem, but then trying to track down WHY is still the question. It’s not doze related, I’ve been actively using my phone. It’s not bandwidth related. That leaves connectivity, and there doesn’t appear to be a reason on either end (for either phone). If there’s a log for the republic app that would be incredibly useful, as I could compare it to the times calls didn’t come through, but I’m not aware of any way to see that.

You have a Moto Z Play, I have a Moto X4 … so our results may differ: but the screenshot you show indicates to me that you have something that shows the top level display (Solid RW Arc, and the VPN lock symbol amongst other things)

  • A one finger swipe down normally provides a view of the Notifications present … which would include the RW Notification of interest, mine looks like this (and the RW Notification should remain the same until it is over written by a new one