"Calls over cell. No access to cell data. messages, .." Moto G5, Android 9

Phone: Moto G5
OS: Android 9
Plan: Measured data 2GB

I cannot get data over cell network, only WIFI. I tried everything google has to offer as far as I can tell, except for factor reset. What is the chance factory reset will fix this and how do I have to restore apps and data after factory reset?

Regards,
David

Hi @davidk.d8neft,

A factory reset is a pretty drastic measure, and will wipe the phone clean of apps and personal content. Would you rather try troubleshooting with our Community before taking that step?

Has the problem always existed, or is it new?

Could you share a screenshot of your the data usage screen in the Settings app?

The G5 does not have Android 9…do you have a different phone or different OS version of Android?

Hi @davidk.d8neft,

It has been nearly a week since we heard from you. Have you been able to get cellular data working? Did you want to troubleshoot with the Community?

1 Like

I am having this same problem, and it started around the same time.

I have a Moto X4 and My Choice + 3 GB plan.

My current data usage is 120 MB, but I can’t get any data unless I am on WiFi.

Would love to troubleshoot with the community, and maybe also help the original poster.

Cellular Data issues fall into two categories

  1. Coverage issues
    What does your cellular signal look like in the top right of your phone? Does it display LTE or 4G on top of the cellular signal? If you don’t mind sharing your zip code we can help you review the coverage in your area.

  2. Phone setting issues
    a) Cellular Data is turned off in the RW app
    Settings -> Data Tools
    Make sure Data Freeze is disabled

b) Cellular Data is being restricted by the Android Settings
Settings -> Networks & Internet -> Data Usage -> Data warning & Limit
Make sure option for Set Data Limit is disabled.

  1. Another useful thing to try is
    How to Refresh the Republic Wireless Activation – Republic Help
1 Like

Ok, great. Here we go…

  1. It says LTE, but with a little “x” over the bars. Under that, it looks like 3 or 4 bars of service.

  2. a) check

b) check

  1. That did it!

So to anybody else having this issue, make sure you Refresh Republic Activation.

Thank you amiti!

1 Like

I think data over cellular stopped working when my phone upgraded from oreo8 to pie 9. I tried all the usual stuff like making sure it was enabled, etc. Did not note LTE vs. 4G but it has not wored anywhere where it worked before. I get the feeling tht pie 9 broke it.

As I noted earlier Pie 9 is not available for Moto G5+…can you please clarify the exact model of your phone?

Oddly, about phone says G6 but I bought a G5. Presumably it changed when the Android ( pie installed. Still not getting data most places but one place I traveled to did. Wierd.

That is most unusual…in order for us to continue debugging here on the community we will need you to come back with responses so that we can try to help you to get to the bottom of this. If you prefer individualized support, I recommend you submit a help ticket.

Is this your first phone with RW?
Has Cellular Data worked as expected in the past prior to the Pie upgrade?
Can you shed more light on the fact that you think you bought a G5 while the phone says it is a G6? Did you acquire the phone from RW or elsewhere?
What does the cellular signal show? Does it show anything above the signal like LTE or 4G? Or perhaps an “x” on top of the signal?
If you don’t mind, can you share your zip code?
Also, it may help if you could let us know what type of SIM card you have.
To determine your SIM card type…open your RW app.
Tap on :settingsicon: -> About
And let us know what it says for “SIM Type

I was mistaken. My Moto is in fact G6 according to the email receipt from RepublicWireless on 7/30/18. I don’t know how I got so confused.

  • Not my first RW phone.
  • Don’t think Data worked right after Pie upgrade.
  • I’ll have to check LTE/4G status.
  • Zip: 98632.
  • SIM: CDMA (ISIM)

Thanks!
David

Hi @davidk.d8neft, thank you so much for recapping that info… you might have mentioned some of this info in earlier posts…but to get a quick snapshot is helpful…and will hopefully drive us to a quick resolution of your issue.

See the instructions in this post

Thank you, amitl. I dialed *#*#72786#*#* and now it works. I did dial reset strings before but don’t remember which number.

Regards,
David

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer