Calls over cell, wifi connected

I have to restart my Moto g to get calls on WIFI. Then at some point, it goes back to Calls Over Cell. Ck’d settings, any ideas?

Is there a problem with using cellular for calls?

I have been noticing this happening more often over the past 6 months on my Moto E. When it happens, I turn off the WiFi for 20 seconds, and then re-enable it. That usually fixes the problem for a while. I have also noticed that about half the time, if I am on a long call, it will switch back to cell sometime during the call, but will use WiFi if I make another call soon after. Not sure what has happened that is causing this. Thank goodness I have a strong cell signal here.
Well, it figures. As soon as I wrote the above suggestion, it fails to work for me. I power cycled the router and that fixed the problem.

  • Power cycling a router/modem is probably the best 1st attack on WiFi problems, even to the point where some manufactures are providing the ability to schedule them.
1 Like

I like to keep my phone on airplane mode ( to keep cellular off ) and just have my WiFi enabled at work ( very dense building that offers free WiFi ). I also have WiFi at home so no need to keep two radios going at the same time. And yes, if I try to make a call sometimes it states “Please Turn Off Airplane Mode” I normally reboot the phone and it will work again. I will however try your (@gator73) toggle WiFi on and off the next time I see this issue. I do suggest jbens idea of rebooting your modem and router at least once a month just for a general maintenance routine.

When I get that message I reset the RW connections in the app (advanced).

I am constantly losing the connection to RW’s servers for WiFi calling.

1 Like

Will do that now! Tanks!

1 Like