Can not make outbound call to Frontier landline

What phone do you have? 3 different phones with Republic all do the same thing. But let’s use my Motorola G7 Play. (there’s a samsung A10 and Motorola Stylus 2021 also)

What plan are you on? My choice

Does your plan include data, or just talk & text? yes data


None of our repbulic wireless phone’s can make an outbound call to our Frontier home phone number. We have rebooted phones. I contacted Fontier and they have checked the line and tested and looked to see if our number had been blocked. No issues. I unistalled the Google Phone updates. No change. Republic wireless app is current. Had others from other carriers call home line, no issues. (that includes cell phone users) I can call my repbulic wireless phone number from my Frontier landline number and it goes through, but if I try to call the home number from the cell number it will not even dial. Have tried this on wifi calling and cellular calling. Have tried with battery saver off. Have tried with wifi off and just cellular on. We are at a loss. I’m waiting on a response from a trouble ticket. This issue has to be solved or we have to drop republic service. Again, it is only outbound calls from our 3 republic phone numbers on 3 different cellphones to our Frontier Communications landline and the phone company has tested and checked and found no problems. Any ideas?

Sounds like a routing issue that Republic Wireless will have to address with their VoIP carrier partner. Keep working with them through your help ticket.

thanks. Still waiting for a reply on the help ticket. but thanks for the possible problem.

I had a similar problem with Republic’s VoIP partner (bandwidth.com) and a Frontier line some years back. I’m sure they’ll get it resolved.

Message an
Expert customer