Can not text another Republic Wireless User over cellular

LG Stylus Phone- Android version 10- purchased from Republic Store June 2020

Unlimited Talk & Text plan with NO data


Issue Description

My wife has a Google Pixel 4 phone (purchased in July 2021) with Republic plan +2GB data. When I try to send a text to her, via Google Messages, if I am on WiFi, the message will send just fine, no problems. It shows it Sent and then Delivered and while I stay on Wifi, she can reply back to me just fine. However, when I am not on Wifi and using the Cellular signal, the message just says it is Sending… But when I tap on the message, it asks if I want to switch to SMS/MMS and I click switch and then it sends. However, when she replies back to me, I don’t get her message back until I am back on a wifi network. I did a little reading here on the Republic site and there was something about disabling the RCS chat feature and so I did on my phone and that just made things a real mess. I couldn’t send, or at least I thought it wasn’t sending, but then my wife was getting the message and would reply back to that message, yet it still showed on my phone the message was trying to send. Help! I don’t understand why I can’t simply send a text to my wife when I am just on the cellular signal and then get her reply back to me. What am I missing? Thank you to any help that can be given!

Sounds like a cellular data issue.

  1. I see that you are on the NO Data plan, but you still need to keep your cellular data turned on in order to be send and receive text messages.
  1. If your cellular data is on and you’re still not receiving texts then it could be a coverage issue. What does your cellular signal indicator look like? You might find this useful

Hi @MarkDeming

I think you may have been on the right track here, although checking your data settings is also a good idea.

Did your wife also disable the RCS chat feature on her phone? It’s possible you’re sending as SMS, but her phone is still trying to send as RCS.

If she still has RCS enabled, there’s a setting you might try adjusting. When you open the conversation between you and her on her phone, tap the three dot :dots: menu icon at the top right. Then tap details and see if there’s a toggle for “Only send SMS and MMS messages.”

image

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer