Can’t answer incoming calls on moto g6

Somebody else asked this, but the thread is closed, and the answer (clear cache and data) doesn’t work for me. The phone rings and the screen lights on incoming calls, but the screen doesn’t accept swipes. The on/off button works but takes several seconds to respond. Could this be caused by a virus? How can I tell if I have a virus, and how can I remove it?

Hi @richardk.yppsmx and welcome back to the community. If the phone icon no longer shows when receiving an incoming call the following might help.

If this does not describe your problem come on back and maybe others in the Community will have a solution!

Okay, I tried Reset app preferences. It is still not working.

Hi @richardk.yppsmx,

Do you see the buttons that one swipes to answer and your phone’s touchscreen doesn’t respond? If so, is your phone’s touchscreen otherwise responsive?

Or, do you not see the buttons at all?

As the community weighs in with troubleshooting and request for additional information, let me add one more thought.

  • Often 3rd party apps (sourced from Google Play and others) are often found to cause ‘strange’ problems.

Thanks for the tip. I have been using this g6 since they were first offered nearly two years ago, and I didn’t realize (until now) I have to grab the green banana before swiping up or down to accept or reject the call. Now I have to go wipe he egg from my face…


My mother…had the same difficulty when her E3 updated, and they changed the motion and icon for answering a call. I often heard from her that “the phone would not answer the call”

The G7 Play she has now, has a different looking and direction to answer, so she had to learn that too.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer