Cannot manage my data. You do not have permission to change the plan on this phone


#1

Updated the app this evening and now when I click on “Manage My Data” and login it says:

You do not have permission to change the plan on this phone. Please sign in as the account owner of this phone to continue.

But I AM the “account owner.” I haven’t assigned any “users.”


Republic Wireless App Update: Version 3.17.1.1
#2

Hi @wcader,

I’ve moved your post because it’s not specific to our 3.17 announcement.

Have you recently moved your SIM card from one phone to another?


#3

Yes, I moved it from my Moto G5 Plus to my Moto E4 Plus.


#4

Ok, please try these steps so our system can recognize that your E4 Plus has the rights to sign into your account:

  1. Please remove the SIM card from the Moto E4 Plus.

  2. With the Moto E4 Plus on Wi-Fi, please follow these steps: How to VOIP Your Phone – Republic Help

  3. Re-insert the same SIM card into the E4 Plus and allow it to “activate.”

  4. Once that process is complete, please try logging into your account again.


Change my data!
#5

Thanks so much. I’ll give it a go!


#6

I recently had a problem signing into my account too, tried repeatedly.

You may want to give it a little while to correct the glitch and/or turn your phone off/on.


#7

I followed your instructions and screen says “Activation Underway.” Thanks so much! :slight_smile:


#8

Don’t thank me too soon! Once it completes, please let me know if you can then log into your account and make the plan change as intended.


#9

Hi, I’m having the same issue with my Pixel. (Recently got a replacement for a broken Pixel, so I’ve also recently moved my SIM card to this phone.) I followed your instructions and it did not resolve the issue. Any other advice? Thanks in advance!


#10

Hi @treyandmaggie,

Is it the same issue - you can’t change the plan?

Can you tell us what Android build is on the Pixel?


#11

Hi @southpaw, I reached the end of my data limit and was trying to add 1 GB of data. I received this message when I clicked “Manage my Data” in the Republic app. I’m running Android 8.1.0.


#12

Hi @treyandmaggie,

I was curious about the actual build number, for example, OPM2.171019.029. When the build on the phone is not supported, you may see that same error.

If your build is the one I just named, please try again and see if the issue is solved now.


#13

Yes, that is the correct build. I just redid the steps you described & it’s working now. Thank you!


#14

I was having the same issue (had just switched to a new Pixel). Following those steps (How to Refresh the Republic Wireless Activation – Republic Help) fixed it for me as well! Thank you!