Cannot send texts or listen to voicemail when on work Wifi or when wifi is unavailable

#1

I have a Moto G5S+, which I recently bought, having used the Moto E previously. I do not have any data with my current plan (the My Choice plan, talk and text only). With the Moto E texts would take a long time to send while wifi was off, but as long as it was off the text would usually send. But since switching to the G5S, I am no longer able to send OR receive texts when away from my home wifi, including when Wifi is off or when I am at my work’s restricted wifi. I also cannot listen to voicemail away from my home wifi or even see that a voicemail was left.

I am currently getting a message while at work: “Voice calls only, no access to cell data, messages, or voicemails”. I have made sure Enhanced 4G LTE Mode is on. I have made sure Cellular Data is on and Data Saver is off. I have not been able to discover what setting I have differently than on my last phone which keeps me from being able to text when I was able to do it on the previous phone.
Thanks for any suggestions.

EDIT: to clarify, on my last phone I could not send MMS or picture texts while away from Wifi, but I could send single recipient, text only messages. Now I can’t do either.

#2

Have you opened a support ticket on this problem? I don’t have a solution but, for sure, you should be able to send and receive SMS with or without WiFi, providing you have a usable cell signal when not on WiFi. You have to have one or the other, but, either should work. You may want to open a support ticket, in addition to asking for community help.

#3

Your Moto E was using the Sprint towers. Perhaps the Moto G5S+ is using T-Mobile towers. If you didn’t buy it from RW you can be certain it is using T-Mobile. Where did you get it? What is your ZIP code?

#4

Hi @michael.dunkerton,

Your Moto G5S+ (unlike your Moto E) requires a data connection for text messaging. You don’t pay extra for cell data used for text messaging but access to cell data where WiFi is unavailable is required.

Amplifying @billg’s suggestion, we might be more helpful if we knew both the cellular partner and your location (zip code). For the former, please dial *#*#786#*#* and tell us what happens. Does the screen clear or are you presented with a “SprintDM” menu?

#5

The screen clears when I dial that number. My zip code is 16507. I bought the phone from Republic so I assumed it would still be under Spring but I’m not sure.

#6

It appears you have a GSM SIM. Contact RW Support and they will switch you to CDMA.

#7

It’s an option but might be jumping the gun. GSM coverage for Erie, PA looks good (as does Sprint’s CDMA coverage).

@michael.dunkerton, you might try the following steps. I understand, you’ve already done some of them.

“VoIP” your phone:

Tap the Phone icon.
Tap the Dialer icon.
Dial ##8647##
The dialer will disappear. If an activation screen appears, wait for the process to finish, then tap GREAT THANKS!.
The Republic Wireless notification icon may disappear briefly then reappear. If the icon does not reappear after one minute, restart your phone.

At Settings -> Data usage; please be certain Cellular data is toggled on.

At Settings -> More -> Cellular networks; please be certain Data roaming is toggled on.

Lastly try resetting your network settings. Please know this step will clear out any saved connections for WiFi and Bluetooth. To do so:

At Settings -> More -> Network settings reset; read the warning then tap “Reset Settings.” You will be warned a second time. Tap “Reset Settings” to confirm. The process will usually take 5-10 seconds and the cellular signal bars icon will go away for a moment. Once the cell signal bars icon returns, please restart your phone.

1 Like
#8

I had already done the Data usage and Cellular Networks. I did the VoIP step and reset the network settings and one of those appears to have solved the problem! Thank you!

1 Like
* Kudo & Win! *
closed #9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Message an
Expert customer