Cannot text on cell service, Wifi text works fine


#1

What phone do you have? Motoroloa XT1031 (MotoG)

What plan are you on? Wifi+CellTalk+ Text Plan

Does your plan include data, or just talk & text? Data on Wifi only, Cell text and talk

Issue Description

Just began using this phone again on a regular basis and noticed that Text messages do not send when I am not on wifi. Calls go through OK though on the cell service. My wife has the same phone and it has the same issue; any ideas on how to fix this would be welcome.

Regarding things I have already tried, I guess none. I did search the help base here and did not see any comparable entries which surprised me.

Thx!

Matt Bauer


#2

Have you tried the looking through this Help Article.

Be sure u have the most recent system updates, the R.W. app is upto date, and you are using Messages (by Google) or Republic Anywhere as your default texting app.

Note: Network maintenance is being done tonight (5-28) from 1am to 8am EST. So the Refresh Activation step may not work until after that time period.

Hope this helps.


#3

Hi Speeding Cheetah!

Thanks for the link, I’ll check the troubleshooting guide in the morning and see if I can get this working.

I have checked and the republic app is 2.1.6.2311 (latest for Android 5.1?) and the Motorola update apps are up to date. My wife uses the default message app and I use the Republic app and the symptoms on both are the same so I suspect finding the issue with one will fix both. It may just be time for a new phone, these are several years old already .

I appreciate the prompt reply, have a wonderful holiday weekend!

Matt Bauer


#4

My mother still uses that same model phone as she wants a small sized phone and stay on the older cheap Refund plan.
It’s a bit slow these days and the camera isn’t that great, but it still does a lot more for her than her old flip phone.

Hope those steps resolve your issue. If not, i’m sure the other members of the community will chime in to try and help.

Enjoy your weekend as well.


#5

I’m having the same problem with my husband’s Moto G 4th gen. It started a few days ago and its very frustrating to not be able to find a fix for it. I have tried everything in the troubleshooting guide. A lot of my friends/family are having the same issue with their RW phones. Strange thing is, my old Moto E 1st gen is still working fine.


#6

So far our Moto g1 phones are still having problems, did a factory reset yesterday but haven’t been out of wifi range yet to test. Will know in late morning today and will update. I will email for support if the reset doesn’t work. Thx for letting me know that other folks are having identical issues.


#7

Phone: MotoG -XT-1031

Republic Wireless App Version: 2.1.6.2311


#8

I, too, have been unable to send or receive texts (using Republic Anywhere) when not on WiFi.

I’m using a Moto G5 Plus with App Version: 3.20.2.1 which it says is “Up to date”. My husband has the Moto G (1st generation) and has no problem with it.

Am going to open a “help ticket” if there is no solution on this forum in the next couple days.

Laura


#9

My son and I each have a MotoG 5 plus (I got mine in January, my son just got his last month) and we also have this problem- we can’t always text (or call) when we are not on wifi. Sometimes, in some areas, it will text. Other times, it won’t, and it won’t place calls either. (Republic Wireless app is up to date with 3.20.2.1, using Google Messages). This is a new problem; our Moto E’s 1st gen had no such problem. We both have the $15 My Choice Talk and Text plan.


#11

The MotoG 1 phone we have are on the Republic 2.0 software but the problems certainly sound similar. Ours would talk but not text on the cell service and sometimes I could not dial out on the wireless (on a known good wireless system). The phone would show a good wireless connection both in the app and the desktop icon but the call would time out without ever connecting.

As I said above, my solution was the nuclear one, factory reset the phones and rebuild. No troubles the last couple days anyway, but time will tell. I think Laura above really had the best idea though, submit a help ticket. This sounds like an issue support needs to know about. :grin:


#12

Just notice that my email yesterday did not include the body of the text for some reason. So, this is what I did to make the phones work:

OK, after trying everything I could find in the help sections which included everything from checking all of the network settings for the Republic and Motorola apps to resetting the Republic and Motorola apps; it looks like the final solution for me was to factory reset both phones. Took a couple hours each to complete - I discovered the phones had not been backing up to the gmail accounts properly so I had a bit of rebuilding to do but both phones seem to be working on the cell network as well as the wireless networks today with the latest version of the Republic app for the MotoG 1.

A couple works of advice that I am sure Support would have give to me if I had asked:

  1. Backup all of your personal items locally (to a flash drive or laptop) before factory resetting the phone. The usual stuff, photos, books, downloads etc… - Factory reset will wipe all data from the user area of the phone.

  2. Check the date on the backup in the gmail account to see how current it is. In android 5.1, I did not see a way to force a backup to be made. Newer versions may vary.

  3. Check the contacts list in the gmail account against the one in the phone in case the backup is not completely current.

Thanks to all for the tips and links, it is all OK in the end but was pretty frustrating for a while there.

Salutations and wonderful days to all!


#13