Cannot update Republic Wireless app - clicking on prompt gets to "try again"

What phone do you have? Moto G7 Play

What plan are you on? My Choice

Does your plan include data, or just talk & text? Includes data


Issue Description

Since July 6 a.m. have been getting the prompt to update to 3.29.3.4, Every time I click it I get the sleepy satellite picture, “try again” and an invitation to play the hot air balloon game. (I have enough ways to waste my time, thanks.)

The update info on the republic help site indicates roll out was “complete” on July 2.

A) Should I even care about this?
B) If so, what does it take to make it work?

It is always best to run with the latest RW App. As you didn’t mention how you were trying to update, you might want to consult: How to Update the Republic Wireless Application – Republic Help as it covers both current and back level Google Play Store.

Tried that too. Clicking update gets me a message that “something went wrong,” but without the cute picture and game. I’ve restarted the phone. No change.

Hi @cynthiah.7o2j9q,

Are you able to download or update apps other than Republic’s at Google’s Play Store?

Yes, I am able to download other apps

Hmm, that’s odd because the sleepy satellite picture you describe suggests you are offline (no active Internet connection). Is this what you saw when attempting to update Republic’s app:

That’s very close, but mine does not say I’m offline and I’m not. I only have the “try again” button.

Good morning @cynthiah.7o2j9q,

It’s a Play Store issue of some sort. And, you get this message only when attempting to update Republic’s app? Updating other apps doesn’t produce the error?

My next suggestion would be the following:

2 Likes

That worked, thank you!

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer