Can't Access Starbucks "sign in"/"terms" page


#1

What phone do you have? Moto E

What plan are you on? Refund

Does your plan include data, or just talk & text? yes, but I also buy data

I have an app on my phone I use to communicate with my car. I have used it in Starbucks forever. I understand Starbucks has changed some of how their free wifi works. Now when I go in SB my arc goes solid showing, Calling, texting and data. My app doesn’t work. I pull down the arc and see I need to verify the terms for the net work. I select verify terms and a Blank Republic Wireless screen appears.

From other reading I have done it might be that the sign in appears and disappears very quickly. If so, it is too quick for me to see.


Issue Description


#2

Hi @elizabeths.qxm3gq

Which model Moto E is this? Republic supports the E1, E2, E4 and E5 Play. You can check using the Settings app.


#3

Moto E2…

Thanks,

Beth


#4

Please open the Republic Wireless app and touch the gear-shaped icon in the upper right corner of the app screen.
Select WiFi Settings
Are the following two options checked or unchecked?

“Ask me to join WiFi networks”
“Help me with extra verification”


#5

Yes, both are checked. I works fine with the Pizza shop 5 doors down which I also have to verify. Except there it give me the choice to verify with google or Republic. I choose google. I don’t get the same choice at StarBucks.


#6

Have you updated the Republic Wireless and Telephony apps? If not, please do so by opening Google Play Store app.


#7

Hi @elizabeths.qxm3gq,

It sounds like the “Help me with extra verification” process is trying to sign in for you. If it’s not working, try “forgetting” the Starbucks network before the next time you go, so that the app won’t try to automatically sign in.


#8

Still fails. Forgot network. Unchecked “help me”, rebooted no difference


#9

Try to launch a browser window such as Chrome and see if it gives you the login page to complete the extra verification.


#10

Thanks,

I have tried that too, but the browser won’t launch because of no internet access…

Beth


#11

Try to connect to this web address

http://127.0.0.1

Also known as localhost… that should give you the verification page.


#12

Thank you,

I wrote it down. I will try it next week when I visit the store.

Beth


#13

Good luck…let us know how that works for you.


#14

amitl,

You win the prize!!! I connected today. The solution was to open chrome. Once I opened chrome the rest was magic…Very quickly connected to the network.

Thank you all so much for the help!

Best,

Beth


#15

You’re very welcome…glad to hear it worked for you!
The localhost trick or clearing browsing data of chrome are good workarounds if Chrome doesn’t automatically take you to the login page.