Can't answer private number calls

Moto G7 need to be able to answer private number calls from my doctor’s office for Telehealth appointments. The calls go straight to voicemail.

The easiest thing to do - without changing your spam call block settings - is to add your doctor as a contact.

4 Likes

If the suggestion from @ceedee is not successful:

Check to see that “Block unknown numbers” is not enabled in the Phone app:

  1. Open your Phone app .
  2. Tap More More|Autox18.
  3. Tap Settings and then|autox18 Blocked numbers .
  4. Turn off Unknown .

This will unblock calls from private or unidentified numbers.

It’s possible you may have to disable Republic Wireless’s spam blocking, also:

5 Likes

That will not work as they block caller ID as the phone has no idea where the phone call is coming from.

@raeanns Were you ever able to get this figured out?

Message an
Expert customer