Can't get data when on cell instead of wifi. Recent problem on my Motorola X-4

I have a Motorola X4 that I’ve been very happy with for quite some time. Plan is the Choice plus 1 GB data. No unusual problems until past few months. And, yes, I have the cell data enabled, and their appears to be plenty of unused data available. All works okay when on my wifi or connected to one when away from the house. Since I’m a definite senior it may be something that’s connected with abilities with increasing age, but it’s fairly recent and is a problem no matter what the cause so if someone can offer answers to try I’d appreciate it.

When I try to do a search on cell without wifi I get a message saying I don’t have data on cell “Look for a wifi”. Same with SMS, or other apps. I do receive email and phone calls. I’m hoping this is something simple, perhaps related to my ignorance but I’ve not been able to figure it out.

I’ve checked settings and they appearunchanged from previous days when all worked.

Suggestions? (much appreciated)

Some thoughts:

2 Likes

Thanks. I’ll try these suggestions and keep my fingers crossed. As usual my appreciation to members of the community.

1 Like

The answer above seem to take care of the problem. Once again, thanks to y’all…

2 Likes

Thanks for the feedback, feel free to chime in when you see someone else with this problem.

One of the things that is really an asset with Republic is the helpfulness and knowledge of the community experts. It sure worked for me this time.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer